summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
-rw-r--r--krita-pyqt5.11.patch19
3 files changed, 9 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e10926b29a2..0f122e9393f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = krita-minimal
pkgdesc = Edit and paint images (less KDE dependencies)
- pkgver = 4.1.0
- pkgrel = 2
+ pkgver = 4.1.1
+ pkgrel = 1
url = https://krita.org
arch = x86_64
license = GPL3
@@ -42,18 +42,16 @@ pkgbase = krita-minimal
optdepends = krita-plugin-gmic: G'MIC plugin
optdepends = python-pyqt5: for the Python plugins
optdepends = libheif: HEIF filter
- provides = krita=4.1.0
+ provides = krita=4.1.1
conflicts = calligra-krita
conflicts = krita-l10n
conflicts = krita
- source = https://download.kde.org/stable/krita/4.1.0/krita-4.1.0.tar.gz
- source = https://download.kde.org/stable/krita/4.1.0/krita-4.1.0.tar.gz.sig
- source = krita-pyqt5.11.patch
+ source = https://download.kde.org/stable/krita/4.1.1/krita-4.1.1.tar.gz
+ source = https://download.kde.org/stable/krita/4.1.1/krita-4.1.1.tar.gz.sig
source = replace-code.patch
validpgpkeys = 05D00A8B73A686789E0A156858B9596C722EA3BD
- sha256sums = 78792df8165b986b806dcf9960a2679f683f2263e06f3ad5a24b0f78d8f27ed5
+ sha256sums = 5cab10343f97a9944a1ab2e137cd0ade6029ce157118009660af286eb75ce9e3
sha256sums = SKIP
- sha256sums = 37aa93119c759d80829112f169f64c47450f218e0fe05fc2e16ae54ff8170db2
sha256sums = 1e076c7de3ee1bd6622cd40d227d0c687170b410f0e297f78f97e0b7f7270d6d
pkgname = krita-minimal
diff --git a/PKGBUILD b/PKGBUILD
index dca2dbf440ad..6c40e71b0033 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=krita
pkgname="${_pkgname}-minimal"
-pkgver=4.1.0
-pkgrel=2
+pkgver=4.1.1
+pkgrel=1
pkgdesc='Edit and paint images (less KDE dependencies)'
arch=(x86_64)
url='https://krita.org'
@@ -22,18 +22,15 @@ optdepends=('poppler-qt5: PDF filter'
provides=("${_pkgname}=${pkgver}")
conflicts=(calligra-krita krita-l10n "${_pkgname}")
source=("https://download.kde.org/stable/krita/$pkgver/${_pkgname}-$pkgver.tar.gz"{,.sig}
- 'krita-pyqt5.11.patch'
'replace-code.patch')
-sha256sums=('78792df8165b986b806dcf9960a2679f683f2263e06f3ad5a24b0f78d8f27ed5'
+sha256sums=('5cab10343f97a9944a1ab2e137cd0ade6029ce157118009660af286eb75ce9e3'
'SKIP'
- '37aa93119c759d80829112f169f64c47450f218e0fe05fc2e16ae54ff8170db2'
'1e076c7de3ee1bd6622cd40d227d0c687170b410f0e297f78f97e0b7f7270d6d')
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
cd "${_pkgname}-$pkgver"
- patch -Np1 -i '../krita-pyqt5.11.patch' # Fix python plugins with PyQt 5.11
patch -Np1 -i '../replace-code.patch'
}
diff --git a/krita-pyqt5.11.patch b/krita-pyqt5.11.patch
deleted file mode 100644
index 004fbec0c320..000000000000
--- a/krita-pyqt5.11.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/plugins/extensions/pykrita/sip/CMakeLists.txt b/plugins/extensions/pykrita/sip/CMakeLists.txt
-index 1f47f0af1c..d5a24f86ee 100644
---- a/plugins/extensions/pykrita/sip/CMakeLists.txt
-+++ b/plugins/extensions/pykrita/sip/CMakeLists.txt
-@@ -12,9 +12,13 @@ set(SIP_INCLUDES
- ${PYQT_SIP_DIR_OVERRIDE}
- ./krita)
-
-+if(${PYQT5_VERSION} STRGREATER_EQUAL "050b00")
-+ set(SIP_NAME -n PyQt5.sip)
-+endif()
-+
- set(SIP_CONCAT_PARTS 1)
- set(SIP_TAGS ALL WS_X11 ${PYQT5_VERSION_TAG})
--set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector)
-+set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector ${SIP_NAME})
-
- set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${LIB_INSTALL_DIR}/krita-python-libs)
- file(GLOB PYKRITA_KRITA_sip_files ./krita/*.sip)