summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--krita-pyqt5.11.patch19
3 files changed, 29 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caa7eaf57be..3e10926b29a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = krita-minimal
pkgdesc = Edit and paint images (less KDE dependencies)
pkgver = 4.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://krita.org
arch = x86_64
license = GPL3
@@ -15,6 +15,8 @@ pkgbase = krita-minimal
makedepends = opencolorio
makedepends = python-pyqt5
makedepends = libheif
+ makedepends = sip
+ makedepends = python-sip
depends = karchive
depends = kcompletion
depends = kcoreaddons
@@ -46,10 +48,12 @@ pkgbase = krita-minimal
conflicts = krita
source = https://download.kde.org/stable/krita/4.1.0/krita-4.1.0.tar.gz
source = https://download.kde.org/stable/krita/4.1.0/krita-4.1.0.tar.gz.sig
+ source = krita-pyqt5.11.patch
source = replace-code.patch
validpgpkeys = 05D00A8B73A686789E0A156858B9596C722EA3BD
sha256sums = 78792df8165b986b806dcf9960a2679f683f2263e06f3ad5a24b0f78d8f27ed5
sha256sums = SKIP
+ sha256sums = 37aa93119c759d80829112f169f64c47450f218e0fe05fc2e16ae54ff8170db2
sha256sums = 1e076c7de3ee1bd6622cd40d227d0c687170b410f0e297f78f97e0b7f7270d6d
pkgname = krita-minimal
diff --git a/PKGBUILD b/PKGBUILD
index 3276eabf039..dca2dbf440a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=krita
pkgname="${_pkgname}-minimal"
pkgver=4.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Edit and paint images (less KDE dependencies)'
arch=(x86_64)
url='https://krita.org'
@@ -12,7 +12,7 @@ depends=(karchive kcompletion kcoreaddons ki18n kitemviews qt5-svg
qt5-multimedia qt5-x11extras kitemmodels
gsl libraw exiv2 openexr fftw curl boost-libs giflib qt5-declarative hicolor-icon-theme)
makedepends=(extra-cmake-modules kdoctools python boost eigen vc poppler-qt5 opencolorio
- python-pyqt5 libheif)
+ python-pyqt5 libheif sip python-sip)
optdepends=('poppler-qt5: PDF filter'
'ffmpeg: to save animations'
'opencolorio: for the LUT docker'
@@ -22,15 +22,18 @@ optdepends=('poppler-qt5: PDF filter'
provides=("${_pkgname}=${pkgver}")
conflicts=(calligra-krita krita-l10n "${_pkgname}")
source=("https://download.kde.org/stable/krita/$pkgver/${_pkgname}-$pkgver.tar.gz"{,.sig}
+ 'krita-pyqt5.11.patch'
'replace-code.patch')
sha256sums=('78792df8165b986b806dcf9960a2679f683f2263e06f3ad5a24b0f78d8f27ed5'
'SKIP'
+ '37aa93119c759d80829112f169f64c47450f218e0fe05fc2e16ae54ff8170db2'
'1e076c7de3ee1bd6622cd40d227d0c687170b410f0e297f78f97e0b7f7270d6d')
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
cd "${_pkgname}-$pkgver"
+ patch -Np1 -i '../krita-pyqt5.11.patch' # Fix python plugins with PyQt 5.11
patch -Np1 -i '../replace-code.patch'
}
diff --git a/krita-pyqt5.11.patch b/krita-pyqt5.11.patch
new file mode 100644
index 00000000000..004fbec0c32
--- /dev/null
+++ b/krita-pyqt5.11.patch
@@ -0,0 +1,19 @@
+diff --git a/plugins/extensions/pykrita/sip/CMakeLists.txt b/plugins/extensions/pykrita/sip/CMakeLists.txt
+index 1f47f0af1c..d5a24f86ee 100644
+--- a/plugins/extensions/pykrita/sip/CMakeLists.txt
++++ b/plugins/extensions/pykrita/sip/CMakeLists.txt
+@@ -12,9 +12,13 @@ set(SIP_INCLUDES
+ ${PYQT_SIP_DIR_OVERRIDE}
+ ./krita)
+
++if(${PYQT5_VERSION} STRGREATER_EQUAL "050b00")
++ set(SIP_NAME -n PyQt5.sip)
++endif()
++
+ set(SIP_CONCAT_PARTS 1)
+ set(SIP_TAGS ALL WS_X11 ${PYQT5_VERSION_TAG})
+-set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector)
++set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector ${SIP_NAME})
+
+ set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${LIB_INSTALL_DIR}/krita-python-libs)
+ file(GLOB PYKRITA_KRITA_sip_files ./krita/*.sip)