summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--krop.install8
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2db394c30a36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Mon May 25 17:59:04 UTC 2015
+pkgbase = krop
+ pkgdesc = A tool to crop PDF files, with an eye towards eReaders.
+ pkgver = 0.4.7
+ pkgrel = 3
+ url = http://arminstraub.com/computer/krop
+ install = krop.install
+ arch = any
+ license = GPL3
+ depends = python2-poppler-qt4
+ depends = python2-pypdf2
+ source = http://arminstraub.com/downloads/krop/krop-0.4.7.tar.gz
+ md5sums = 43b7c11f09b484a5516bcaf24cd0919e
+
+pkgname = krop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da292780654b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: XavierCLL
+
+pkgname=krop
+pkgver=0.4.7
+pkgrel=3
+pkgdesc="A tool to crop PDF files, with an eye towards eReaders."
+arch=('any')
+url="http://arminstraub.com/computer/krop"
+license=('GPL3')
+depends=('python2-poppler-qt4' 'python2-pypdf2')
+install=$pkgname.install
+source=(http://arminstraub.com/downloads/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('43b7c11f09b484a5516bcaf24cd0919e')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root $pkgdir
+
+ # Desktop icon
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+} \ No newline at end of file
diff --git a/krop.install b/krop.install
new file mode 100644
index 000000000000..cbca450b7706
--- /dev/null
+++ b/krop.install
@@ -0,0 +1,8 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+