summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dee007cfcb4..f889044c84c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = kscript
-pkgdesc = Enhanced scripting support for Kotlin on *nix-based systems
-pkgver = 2.9.3
+pkgdesc = Enhanced scripting support for Kotlin on *nix and Windows based systems
+pkgver = 4.2.3
pkgrel = 1
-url = https://github.com/holgerbrandl/kscript
+url = https://github.com/kscripting/kscript
arch = any
license = MIT
depends = kotlin
-source = kscript-2.9.3.bin.zip::https://github.com/holgerbrandl/kscript/releases/download/v2.9.3/kscript-2.9.3-bin.zip
-sha256sums = d15f4236abb9341c330862fea0fdcdba7818b63953fdb3885720bbc1901666d1
+source = kscript-4.2.3.bin.zip::https://github.com/kscripting/kscript/releases/download/v4.2.3/kscript-4.2.3-bin.zip
+sha256sums = 1dda3b041bc9af41bb0e3b78818ef5c99df845ee0e06a258d117ce70f1ec5941
pkgname = kscript
-
diff --git a/PKGBUILD b/PKGBUILD
index 154ab480d63d..01e62ff0e47b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: Holger Brandl https://github.com/holgerbrandl/kscript/
+# Maintainer: Holger Brandl https://github.com/holgerbrandl, Marcin Kuszczak https://github.com/aartiPl
pkgname=kscript
-pkgver=2.9.3
+pkgver=4.2.3
pkgrel=1
-pkgdesc='Enhanced scripting support for Kotlin on *nix-based systems'
+pkgdesc='Enhanced scripting support for Kotlin on *nix and Windows based systems'
arch=('any')
-url='https://github.com/holgerbrandl/kscript'
+url='https://github.com/kscripting/kscript'
license=('MIT')
depends=('kotlin')
-source=("${pkgname}-${pkgver}-bin.zip::https://github.com/holgerbrandl/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-bin.zip")
-sha256sums=('d15f4236abb9341c330862fea0fdcdba7818b63953fdb3885720bbc1901666d1')
+source=("${pkgname}-${pkgver}-bin.zip::https://github.com/kscripting/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}-bin.zip")
+sha256sums=('1dda3b041bc9af41bb0e3b78818ef5c99df845ee0e06a258d117ce70f1ec5941')
package() {
cd "${srcdir}/${pkgname}-${pkgver}/bin"
@@ -17,4 +17,3 @@ package() {
install -Dm 755 kscript "${pkgdir}/usr/bin/kscript"
install -Dm 644 kscript.jar "${pkgdir}/usr/bin/kscript.jar"
}
-