summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42e794c44a0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ktools-git
+ pkgdesc = Tools for modding of the game Don't Starve, by Klei Entertainment
+ pkgver = 97.8f31242
+ pkgrel = 1
+ url = https://github.com/nsimplex/ktools
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = imagemagick
+ optdepends = libzip: for zip support
+ provides = ktools
+ conflicts = ktools
+ source = git+https://github.com/nsimplex/ktools.git
+ sha256sums = SKIP
+
+pkgname = ktools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d26964df2cc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=ktools
+pkgname=$_pkgname-git
+pkgver=97.8f31242
+pkgrel=1
+pkgdesc="Tools for modding of the game Don't Starve, by Klei Entertainment"
+arch=("i686" "x86_64")
+url="https://github.com/nsimplex/ktools"
+license=("GPL2")
+depends=("imagemagick")
+makedepends=("git" "cmake")
+optdepends=("libzip: for zip support")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/nsimplex/ktools.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}