summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce3c55eb8d02..a10b3cbe55ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = kubergrunt
pkgdesc = Kubergrunt is a standalone go binary with a collection of commands to fill in the gaps between Terraform, Helm, and Kubectl
pkgver = 0.9.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gruntwork-io/kubergrunt
arch = x86_64
license = Apache-2
optdepends = terraform
optdepends = kubectl
optdepends = helm
+ source = https://raw.githubusercontent.com/gruntwork-io/kubergrunt/v0.9.0/LICENSE
source = https://github.com/gruntwork-io/kubergrunt/releases/download/v0.9.0/kubergrunt_linux_amd64
+ sha256sums = d1dc9a105a814822337e0f8eab8668e4eb05bb04b4d6b234c5e9b79b76550a91
sha256sums = 279f895eb9b29595ae795a6e7587ade6a8a3b95c74b4497ce795f75da20793ef
pkgname = kubergrunt
diff --git a/PKGBUILD b/PKGBUILD
index 499bff41b3ac..7816e57856cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=kubergrunt
pkgver=0.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="Kubergrunt is a standalone go binary with a collection of commands to fill in the gaps between Terraform, Helm, and Kubectl"
arch=('x86_64')
url="https://github.com/gruntwork-io/kubergrunt"
@@ -11,10 +11,14 @@ optdepends=('terraform'
'helm'
)
license=('Apache-2')
-source=("https://github.com/gruntwork-io/${pkgname}/releases/download/v${pkgver}/${pkgname}_linux_amd64")
-sha256sums=('279f895eb9b29595ae795a6e7587ade6a8a3b95c74b4497ce795f75da20793ef')
+source=(
+ "https://raw.githubusercontent.com/gruntwork-io/kubergrunt/v${pkgver}/LICENSE"
+ "https://github.com/gruntwork-io/${pkgname}/releases/download/v${pkgver}/${pkgname}_linux_amd64")
+sha256sums=('d1dc9a105a814822337e0f8eab8668e4eb05bb04b4d6b234c5e9b79b76550a91'
+ '279f895eb9b29595ae795a6e7587ade6a8a3b95c74b4497ce795f75da20793ef')
package() {
cd "${srcdir}"
install -Dm755 ${pkgname}_linux_amd64 ${pkgdir}/usr/bin/${pkgname}
+ install -D -m 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}