summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92596d6f3dbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = kubernetes-helmfile-bin
+ pkgdesc = Helmfile is declarative spec for deploying helm charts
+ pkgver = 0.20.0
+ pkgrel = 1
+ url = https://github.com/roboll/helmfile
+ arch = x86_64
+ license = MIT
+ source = https://github.com/roboll/helmfile/releases/download/v0.20.0/helmfile_linux_amd64
+ sha256sums = af4107df13012e094ae0a09ec28952212477517aef4ab3720de42e12833a896a
+
+pkgname = kubernetes-helmfile-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4ca4c0ef9990
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/helmfile_amd64*
+/*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59714627bf01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Anatoly Rugalev <anatoly.rugalev gmail com>
+
+pkgname=kubernetes-helmfile-bin
+pkgver=0.20.0
+pkgrel=1
+pkgdesc="Helmfile is declarative spec for deploying helm charts"
+url="https://github.com/roboll/helmfile"
+license=('MIT')
+arch=('x86_64')
+deps=('kubernetes-helm-bin')
+
+source=("https://github.com/roboll/helmfile/releases/download/v$pkgver/helmfile_linux_amd64")
+sha256sums=('af4107df13012e094ae0a09ec28952212477517aef4ab3720de42e12833a896a')
+package() {
+ cd "$srcdir"
+ install -d "$pkgdir/usr/bin"
+ install -m755 helmfile_linux_amd64 "$pkgdir/usr/bin/helmfile"
+}
+