summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD46
-rw-r--r--kupfer-adds-git.install13
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc5be447925e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = kupfer-adds-git
+ pkgdesc = An interface for quick and convenient access to applications and their documents. Forked by Karol Bedkowski.
+ pkgver = 2013.10.26
+ pkgrel = 4
+ epoch = 1
+ url = https://github.com/KarolBedkowski/kupfer-adds
+ install = kupfer-adds-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gnome-doc-utils
+ makedepends = docutils
+ makedepends = intltool
+ depends = python2-xdg
+ depends = pygtk
+ depends = python2-dbus
+ depends = python2-gconf
+ depends = python2-keybinder2
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ optdepends = gnome-python-desktop: enables all plugins and gnome integration
+ optdepends = python2-keyring: gnome keyring integration
+ optdepends = python2-wnck: tracks running applications
+ optdepends = python2-setproctitle: set process name
+ optdepends = python-gdata: google services
+ optdepends = xautomation: enables the Send Keys plugin
+ provides = kupfer
+ conflicts = kupfer
+ source = kupfer-adds::git://github.com/KarolBedkowski/kupfer-adds.git
+ md5sums = SKIP
+
+pkgname = kupfer-adds-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d276f2a2a382
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Maintainer: SanskritFritz (gmail)
+
+_name=kupfer
+pkgname=${_name}-adds-git
+_gitname=$_name-adds
+pkgver=2013.10.26
+pkgrel=4
+epoch=1
+pkgdesc="An interface for quick and convenient access to applications and their documents. Forked by Karol Bedkowski."
+arch=(any)
+url="https://github.com/KarolBedkowski/kupfer-adds"
+license=('GPL')
+depends=('python2-xdg' 'pygtk' 'python2-dbus' 'python2-gconf' 'python2-keybinder2'
+ 'hicolor-icon-theme' 'desktop-file-utils')
+optdepends=('gnome-python-desktop: enables all plugins and gnome integration'
+ 'python2-keyring: gnome keyring integration'
+ 'python2-wnck: tracks running applications'
+ 'python2-setproctitle: set process name'
+ 'python-gdata: google services'
+ 'xautomation: enables the Send Keys plugin')
+makedepends=('git' 'gnome-doc-utils' 'docutils' 'intltool')
+provides=("$_name")
+conflicts=("$_name")
+install="$pkgname.install"
+source=("$_gitname::git://github.com/KarolBedkowski/kupfer-adds.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ # python2 fixes
+ export PYTHON=/usr/bin/python2
+
+ python2 waf configure --prefix=/usr --no-update-mime --no-update-icon-cache
+ python2 waf
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 waf install -f --destdir="$pkgdir/"
+}
diff --git a/kupfer-adds-git.install b/kupfer-adds-git.install
new file mode 100644
index 000000000000..d236f548643b
--- /dev/null
+++ b/kupfer-adds-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-mime-database /usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file