summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b63e39e57f4..6f0e2f957bac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,9 +4,15 @@ pkgbase = kweather
pkgrel = 1
url = https://invent.kde.org/plasma-mobile/kweather
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = extra-cmake-modules
makedepends = qt5-tools
+ makedepends = qt5-svg
depends = ki18n
depends = kconfig
depends = kcoreaddons
diff --git a/PKGBUILD b/PKGBUILD
index cba75d008df8..ba8888f12005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@ pkgname=kweather
pkgver=0.4
pkgrel=1
pkgdesc="Weather application for Plasma Mobile"
-arch=(x86_64)
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/plasma-mobile/kweather"
license=(GPL3)
-depends=(ki18n kconfig kcoreaddons knotifications kirigami2 kdbusaddons plasma-framework)
-makedepends=(extra-cmake-modules qt5-tools)
-source=("https://invent.kde.org/plasma-mobile/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+depends=('ki18n' 'kconfig' 'kcoreaddons' 'knotifications' 'kirigami2' 'kdbusaddons' 'plasma-framework')
+makedepends=('extra-cmake-modules' 'qt5-tools' 'qt5-svg')
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('94db92197a871d32a64117a4639e905f874f65f64e8975bf92c32f3fd31c70bd')
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S "${pkgname}-${pkgver}"
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S "${pkgname}-${pkgver}"
+ cmake --build build --config Release
}
package() {
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
+ DESTDIR="${pkgdir}" cmake --install build --config Release
}