summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD43
-rw-r--r--kwin-lowlatency.install8
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d852dad69bbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Thu Mar 28 06:53:58 UTC 2019
+pkgbase = kwin-lowlatency
+ pkgdesc = the compositor, with added stutter/latency reductions
+ pkgver = 5.15.3
+ pkgrel = 1
+ url = https://github.com/tildearrow/kwin-lowlatency
+ install = kwin-lowlatency.install
+ arch = x86_64
+ groups = plasma
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ makedepends = kdoctools
+ depends = kscreenlocker
+ depends = xcb-util-cursor
+ depends = plasma-framework
+ depends = kcmutils
+ depends = breeze
+ depends = kinit
+ depends = qt5-sensors
+ optdepends = qt5-virtualkeyboard: virtual keyboard support for kwin-wayland
+ provides = kwin
+ conflicts = kwin
+ source = git+https://github.com/tildearrow/kwin-lowlatency.git
+ sha256sums = SKIP
+
+pkgname = kwin-lowlatency
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ee919b18264
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: tildearrow <acc12345acc at gmail dot com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=kwin-lowlatency
+pkgver=5.15.3
+pkgrel=1
+pkgdesc='the compositor, with added stutter/latency reductions'
+arch=(x86_64)
+url='https://github.com/tildearrow/kwin-lowlatency'
+license=(LGPL)
+depends=(kscreenlocker xcb-util-cursor plasma-framework kcmutils breeze kinit qt5-sensors)
+makedepends=(extra-cmake-modules qt5-tools kdoctools)
+optdepends=('qt5-virtualkeyboard: virtual keyboard support for kwin-wayland')
+provides=(kwin)
+conflicts=(kwin)
+groups=(plasma)
+source=("git+https://github.com/tildearrow/kwin-lowlatency.git")
+sha256sums=(SKIP)
+install=$pkgname.install
+
+prepare() {
+ cd "$pkgname"
+ git checkout d64cb911cd899c1214fb5e0e41b29aad038ba5b2
+ cd ..
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/kwin-lowlatency.install b/kwin-lowlatency.install
new file mode 100644
index 000000000000..5d249b2f744e
--- /dev/null
+++ b/kwin-lowlatency.install
@@ -0,0 +1,8 @@
+post_install() {
+# this is executed by make install, but doesn't work since setcap can only be run as root
+ setcap CAP_SYS_NICE=+ep /usr/bin/kwin_wayland
+}
+
+post_upgrade() {
+ post_install
+}