summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Qt4.patch25
-rw-r--r--PKGBUILD30
4 files changed, 93 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..bf7f6340ca60
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = l2tp-ipsec-vpn
+ pkgdesc = A GUI to manage L2TP over IPsec virtual private network connections.
+ pkgver = 1.0.9
+ pkgrel = 3
+ url = https://launchpad.net/l2tp-ipsec-vpn
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ctemplate
+ depends = openswan
+ depends = xl2tpd
+ depends = qt4
+ depends = l2tp-ipsec-vpn-daemon
+ source = https://launchpad.net/l2tp-ipsec-vpn/trunk/1.0.9/+download/l2tp-ipsec-vpn_1.0.9.tar.gz
+ source = 0001-Qt4.patch
+
+pkgname = l2tp-ipsec-vpn
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52d793b4bfd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = l2tp-ipsec-vpn
+ pkgdesc = A GUI to manage L2TP over IPsec virtual private network connections.
+ pkgver = 1.0.9
+ pkgrel = 3
+ url = https://launchpad.net/l2tp-ipsec-vpn
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ctemplate
+ depends = openswan
+ depends = xl2tpd
+ depends = qt4
+ depends = l2tp-ipsec-vpn-daemon
+ source = https://launchpad.net/l2tp-ipsec-vpn/trunk/1.0.9/+download/l2tp-ipsec-vpn_1.0.9.tar.gz
+ source = 0001-Qt4.patch
+ md5sums = 4679e6fae4e82f285ee39479660ba48f
+ md5sums = df38c669559503a8abb287e081144688
+
+pkgname = l2tp-ipsec-vpn
+
diff --git a/0001-Qt4.patch b/0001-Qt4.patch
new file mode 100644
index 000000000000..4657cae5f822
--- /dev/null
+++ b/0001-Qt4.patch
@@ -0,0 +1,25 @@
+From 446342dcb2ed8e8eebfad2b8d4863ea1cbfd0d5a Mon Sep 17 00:00:00 2001
+From: Red54
+Date: Fri, 6 Jun 2014 02:20:00 +0200
+Subject: [PATCH] Qt4
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 03efcec..e79d33d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,7 +22,7 @@
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+ #
+
+-QMAKE := $(shell if [ -f /usr/bin/qmake ]; then echo "qmake"; else echo "qmake-qt4"; fi)
++QMAKE := $(shell if [ -f /usr/bin/qmake-qt4 ]; then echo "qmake-qt4"; else echo "qmake"; fi)
+
+ # default configuration is release
+ DEFAULTCONF=Release
+--
+2.0.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbba10c87213
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+pkgname=l2tp-ipsec-vpn
+pkgver=1.0.9
+pkgrel=3
+pkgdesc="A GUI to manage L2TP over IPsec virtual private network connections."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/l2tp-ipsec-vpn"
+license=('GPL')
+depends=('openswan' 'xl2tpd' 'qt4' 'l2tp-ipsec-vpn-daemon')
+makedepends=('ctemplate')
+optdepends=()
+source=(https://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}_${pkgver}.tar.gz
+ 0001-Qt4.patch)
+md5sums=('4679e6fae4e82f285ee39479660ba48f'
+ 'df38c669559503a8abb287e081144688')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 < $srcdir/0001-Qt4.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make INSTALL_ROOT="$pkgdir/" -f nbproject/qt-Release.mk install
+}