summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--wlroots_error.patch21
3 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb3639561674..a22331fb527e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = labwc
pkgdesc = stacking wayland compositor with look and feel from openbox
- pkgver = 0.1.0
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/johanmalm/labwc
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = labwc
depends = wayland-protocols
depends = xorg-xwayland
optdepends = bemenu: default launcher via Alt+F3
- source = labwc-0.1.0.tar.gz::https://github.com/johanmalm/labwc/archive/0.1.0.tar.gz
+ source = labwc-0.2.0.tar.gz::https://github.com/johanmalm/labwc/archive/0.1.0.tar.gz
b2sums = 336b2949e2306f9dcbe4786c0b28e70cef0b9d999276d88890e25933297ba433ce297dc0c0e0376c1267bc0d3ff3a7b798db32d04c6f297d2803f5167f8cf503
pkgname = labwc
diff --git a/PKGBUILD b/PKGBUILD
index 78be6221d7af..e902d254ed1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lex Black <autumn-wind@web.de>
pkgname=labwc
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc='stacking wayland compositor with look and feel from openbox'
url="https://github.com/johanmalm/labwc"
@@ -10,10 +10,17 @@ license=('GPL2')
depends=('pango' 'wlroots' 'wayland' 'wayland-protocols' 'xorg-xwayland')
makedepends=('meson' 'scdoc')
optdepends=("bemenu: default launcher via Alt+F3")
-source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/johanmalm/labwc/archive/0.1.0.tar.gz")
-b2sums=('336b2949e2306f9dcbe4786c0b28e70cef0b9d999276d88890e25933297ba433ce297dc0c0e0376c1267bc0d3ff3a7b798db32d04c6f297d2803f5167f8cf503')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/johanmalm/labwc/archive/${pkgver}.tar.gz"
+ wlroots_error.patch)
+b2sums=('ec4853cd2d839253a1389d7cb7216e4f7c8e8e485fd73b919cad6e7f0afe1f168a9aad0d07447b4fe59a56c3118b2886d7c7fd2ea47646854f5781f287424d59'
+ '6305177a8cb60e8aa8018178895e431d61e2bd37cd4fb17ca1470965c235b030952daa02f7e3d251c698e67a2dbd53055e0cdeb18e8a20106c8d1f15f8476b9d')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}"/wlroots_error.patch
+}
+
build() {
cd "$pkgname-$pkgver"
arch-meson -Dman-pages=enabled ../build
diff --git a/wlroots_error.patch b/wlroots_error.patch
new file mode 100644
index 000000000000..78ed475d859c
--- /dev/null
+++ b/wlroots_error.patch
@@ -0,0 +1,21 @@
+commit b997d8e7936de46f4f78a49dc9ae00db46c9e803
+Author: Jan Beich <jbeich@FreeBSD.org>
+Date: Thu Apr 15 20:49:24 2021 +0000
+
+ meson: unbreak with system wlroots after fd4ea3542fdc
+
+ meson.build:50:2: ERROR: All keyword arguments must be after positional arguments.
+
+diff --git a/meson.build b/meson.build
+index a2b86db..2345fc7 100644
+--- a/meson.build
++++ b/meson.build
+@@ -47,7 +47,7 @@ if wlroots_proj.found()
+ wlroots_conf = wlroots_proj.get_variable('conf_data')
+ wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1
+ else
+- wlroots = dependency('wlroots', version: '>=0.13.0', '<0.14.0')
++ wlroots = dependency('wlroots', version: ['>=0.13.0', '<0.14.0'])
+ wlroots_has_xwayland = cc.get_define('WLR_HAS_XWAYLAND', prefix: '#include <wlr/config.h>', dependencies: wlroots) == '1'
+ endif
+ wayland_server = dependency('wayland-server', version: '>=0.19.0')