summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--remove-werror.patch11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44bbc9495792
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = labwc-git
+ pkgdesc = stacking wayland compositor with look and fell from openbox (git version)
+ pkgver = r100.93d5809
+ pkgrel = 1
+ url = https://github.com/johanmalm/labwc
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = meson
+ depends = wlroots
+ depends = wayland
+ depends = wayland-protocols
+ depends = xorg-server-xwayland
+ provides = labwc
+ conflicts = labwc
+ source = git+https://github.com/johanmalm/labwc.git
+ source = remove-werror.patch
+ md5sums = SKIP
+ md5sums = 7a04a45415b125dee8d46dab20039a2c
+
+pkgname = labwc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4326ab3ba972
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lex Black <autumn-wind@web.de>
+
+_pkgname=labwc
+pkgname=labwc-git
+pkgver=r100.93d5809
+pkgrel=1
+pkgdesc='stacking wayland compositor with look and fell from openbox (git version)'
+url="https://github.com/johanmalm/labwc"
+arch=('x86_64')
+license=('GPL2')
+depends=('wlroots' 'wayland' 'wayland-protocols' 'xorg-server-xwayland')
+makedepends=('git' 'meson')
+conflicts=(labwc)
+provides=(labwc)
+source=("git+https://github.com/johanmalm/${_pkgname}.git"
+ "remove-werror.patch")
+md5sums=('SKIP'
+ '7a04a45415b125dee8d46dab20039a2c')
+
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ patch -Np0 -i remove-werror.patch
+}
+
+build() {
+ cd "$_pkgname"
+ arch-meson ../build
+ ninja -v -C ../build
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="${pkgdir}" meson install -C ../build
+}
diff --git a/remove-werror.patch b/remove-werror.patch
new file mode 100644
index 000000000000..bb1475270563
--- /dev/null
+++ b/remove-werror.patch
@@ -0,0 +1,11 @@
+--- labwc/meson.build
++++ labwc/meson.build
+@@ -5,7 +5,6 @@
+ default_options: [
+ 'c_std=c11',
+ 'warning_level=2',
+- 'werror=true',
+ ],
+ )
+
+