summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c07dc26cbb9..af79b993b8a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 1 11:35:46 UTC 2017
+# Wed Feb 1 20:58:48 UTC 2017
pkgbase = lain-git
pkgdesc = Layouts, asynchronous widgets and utilities for Awesome WM
- pkgver = 1530.1555e23
+ pkgver = 1531.a1ba902
pkgrel = 1
url = https://github.com/copycat-killer/lain
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 0b2721dc5619..15eaf1c9544f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: luke bonham <dada [at] archlinux [dot] info>
pkgname=lain-git
-pkgcom=1530
-pkgsha=1555e23
+pkgcom=1531
+pkgsha=a1ba902
pkgver=$pkgcom.$pkgsha
pkgrel=1
pkgdesc="Layouts, asynchronous widgets and utilities for Awesome WM"
@@ -18,11 +18,18 @@ source=("git://github.com/copycat-killer/lain.git")
md5sums=('SKIP')
package() {
- install -dm755 "$pkgdir/usr/share/awesome/lib/lain"
- git --git-dir=lain/.git --work-tree=lain/ reset --hard $pkgsha --quiet
- rm -rf lain/{wiki,.git*,*.rockspec,*TEMPLATE*}
- cp -a lain "$pkgdir/usr/share/awesome/lib/"
+ aw=$(which awesome | grep local) # check if awesome is stable or git
+ if [ -z ${#aw} ]; then
+ aw_path="$pkgdir/usr/share/awesome/lib"
+ else
+ aw_path="$pkgdir/usr/local/share/awesome/lib"
+ fi
- # Fix permissions
- find "$pkgdir" -type f ! -path "*/scripts/*" -print0 | xargs -0 chmod -R 644
+ install -dm755 "$aw_path/lain"
+ git --git-dir=lain/.git --work-tree=lain/ reset --hard $pkgsha --quie
+ rm -rf lain/{wiki,.git*,*.rockspec,*TEMPLATE*}
+ cp -a lain $aw_path
+
+ # Fix permissions
+ find "$pkgdir" -type f ! -path "*/scripts/*" -print0 | xargs -0 chmod -R 644
}