summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b9c63f46b22..eb81fb6dba74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lando-git
pkgdesc = A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology
- pkgver = 3.0.0.rc.1.r284.gd76f66f8
+ pkgver = 3.0.0.rc.13.r12.gc0e229e8
pkgrel = 1
url = https://docs.devwithlando.io
arch = x86_64
@@ -11,6 +11,8 @@ pkgbase = lando-git
depends = docker
depends = docker-compose
optdepends = gcc-libs
+ provides = lando
+ conflicts = lando
options = !strip
source = lando-git::git+https://github.com/lando/lando.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 85e42720b572..7c82a93b774f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,15 @@
# https://bbs.archlinux.org/viewtopic.php?id=235884
pkgname=lando-git
-pkgver=3.0.0.rc.1.r284.gd76f66f8
-_target_version="3.0.0-rc.1"
+pkgver=3.0.0.rc.13.r12.gc0e229e8
+
+# Transform git tag into target version string
+_target_version=${pkgver: 0:-10}
+_target_version=${_target_version%%[[:digit:]]}
+_target_version=${_target_version%%[[:digit:]]}
+_target_version=${_target_version%%.r}
+_target_version=${_target_version/.rc/-rc}
+
pkgrel=1
pkgdesc="A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology"
arch=('x86_64')
@@ -15,6 +22,8 @@ optdepends=('gcc-libs')
makedepends=('npm' 'yarn' 'git')
source=("${pkgname}::git+https://github.com/lando/lando.git")
sha256sums=('SKIP')
+conflicts=("lando")
+provides=("lando")
# strip breaks executable
options=(!strip)