summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD20
-rw-r--r--lantern-beta.install33
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39f56b82a00d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lantern-beta
+ pkgdesc = Lantern is a free desktop application that delivers fast, reliable and secure access to the open Internet. (Stable Channel)
+ pkgver = 2.0.1.20150821.200810
+ pkgrel = 1
+ url = https://getlantern.org
+ install = lantern-beta.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = libappindicator-gtk3
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ provides = lantern
+ options = !emptydirs
+ options = !strip
+ options = !docs
+ source_i686 = lantern-installer-32.deb::https://raw.githubusercontent.com/getlantern/lantern-binaries/master/lantern-installer-32.deb
+ sha1sums_i686 = c1879554862ac7dc9590a1bb119c7638fbd3467f
+ source_x86_64 = lantern-installer-beta-64-bit.deb::https://raw.githubusercontent.com/getlantern/lantern-binaries/master/lantern-installer-beta-64-bit.deb
+ sha1sums_x86_64 = 9978b58487377ff572c9bfbd926085b2713b7028
+
+pkgname = lantern-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4109a7608fe6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=lantern-beta
+pkgver=2.0.1.20150821.200810
+pkgrel=1
+pkgdesc='Lantern is a free desktop application that delivers fast, reliable and secure access to the open Internet. (Stable Channel)'
+arch=('i686' 'x86_64')
+url='https://getlantern.org'
+license=('Apache')
+depends=('libappindicator-gtk3' 'hicolor-icon-theme' 'xdg-utils')
+provides=('lantern')
+options=('!emptydirs' '!strip' '!docs')
+install=$pkgname.install
+source_i686=('lantern-installer-32.deb::https://raw.githubusercontent.com/getlantern/lantern-binaries/master/lantern-installer-32.deb')
+source_x86_64=('lantern-installer-beta-64-bit.deb::https://raw.githubusercontent.com/getlantern/lantern-binaries/master/lantern-installer-beta-64-bit.deb')
+sha1sums_i686=('c1879554862ac7dc9590a1bb119c7638fbd3467f')
+sha1sums_x86_64=('9978b58487377ff572c9bfbd926085b2713b7028')
+
+package() {
+ msg2 'Extracting the data.tar.xz...'
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+}
diff --git a/lantern-beta.install b/lantern-beta.install
new file mode 100644
index 000000000000..fa46fd905850
--- /dev/null
+++ b/lantern-beta.install
@@ -0,0 +1,33 @@
+# Colored makepkg-like functions
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+
+ msg_blue "Updating icon cache.."
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+}
+
+post_install() {
+ _update
+}
+
+post_upgrade() {
+ _update
+}
+
+post_remove() {
+ _update
+}