summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 796864ece8ac..21a8ddcf55c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = last-mission-sdl
pkgdesc = Side-view arcade game (inspired by Underwurlde and Starquake)
pkgver = 0.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dmitrysmagin/last-mission
arch = i686
arch = x86_64
license = GPL
depends = sdl_mixer
- source = last-mission-sdl-0.8.tar.gz::https://github.com/dmitrysmagin/last-mission/archive/81cb1b45aa2e24e088440910bb764d5daa6f5028.tar.gz
- sha256sums = 1acf05deb0efe14abf7cea92dd62fe5c67de817c4eda4ba296f4c6bb9e1deb3d
+ source = last-mission-sdl-0.8.tar.gz::https://github.com/dmitrysmagin/last-mission/archive/refs/tags/v0.8.tar.gz
+ sha256sums = 78a46b53a5f559c7972cb1cf5e0fe2d6db2b3b358d465f29bebae54228ccdb62
pkgname = last-mission-sdl
-
diff --git a/PKGBUILD b/PKGBUILD
index 92b111063f5c..40bdcfc60790 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,30 @@
pkgname=last-mission-sdl
pkgver=0.8
-_githash=81cb1b45aa2e24e088440910bb764d5daa6f5028 # this is needed as there are no tags
-pkgrel=1
+pkgrel=2
pkgdesc='Side-view arcade game (inspired by Underwurlde and Starquake)'
arch=('i686' 'x86_64')
url="https://github.com/dmitrysmagin/last-mission"
license=('GPL')
depends=('sdl_mixer')
-source=($pkgname-$pkgver.tar.gz::"https://github.com/dmitrysmagin/last-mission/archive/$_githash.tar.gz")
-sha256sums=('1acf05deb0efe14abf7cea92dd62fe5c67de817c4eda4ba296f4c6bb9e1deb3d')
+source=($pkgname-$pkgver.tar.gz::"$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('78a46b53a5f559c7972cb1cf5e0fe2d6db2b3b358d465f29bebae54228ccdb62')
prepare() {
- cd last-mission-$_githash
+ cd last-mission-$pkgver
# change data directory
sed "s|sound/|/usr/share/$pkgname/&|g" -i sound.c
- # add define and lib to fix build and add our build flags
- sed 's|CFLAGS =\(.*\)|CFLAGS += -D__UNIX__ \1|;s|$(LFLAGS)|$(LDFLAGS) & -lm|' -i Makefile
+ # add defines and library to fix building and add our build flags
+ sed -e 's|CFLAGS =\(.*\)|CFLAGS += -D__UNIX__ -DDEBUG \1|' \
+ -e 's|$(LFLAGS)|$(LDFLAGS) & -lm|' -i Makefile
}
build() {
- make -C last-mission-$_githash
+ make -C last-mission-$pkgver
}
package() {
- cd last-mission-$_githash
+ cd last-mission-$pkgver
# binary
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname