summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64ba032d037b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lastfm_cg-git
+ pkgdesc = Lastfm Collage Generator
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/dbeley/lastfm_cg
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ depends = python-pillow
+ depends = python-numpy
+ depends = python-pylast
+ depends = python-requests
+ provides = lastfm_cg
+ conflicts = lastfm_cg
+ source = git+https://github.com/dbeley/lastfm_cg
+ md5sums = SKIP
+
+pkgname = lastfm_cg-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e92f57d4647
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+tags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef36be40cbdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: David Beley <dbeley@protonmail.com>
+pkgname=lastfm_cg-git
+pkgver=1.1
+pkgrel=1
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+pkgdesc="Lastfm Collage Generator"
+arch=('any')
+url="https://github.com/dbeley/${pkgname%-git}"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-setuptools'
+ 'python-pillow'
+ 'python-numpy'
+ 'python-pylast'
+ 'python-requests'
+ )
+source=("git+https://github.com/dbeley/${pkgname%-git}")
+md5sums=("SKIP")
+
+package() {
+ cd "${pkgname%-git}"
+ #python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}