summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc8c8a2ce48d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lastfmlib
+ pkgdesc = A library that provides an implementation of the Last.fm protocol
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://code.google.com/p/lastfmlib/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = curl
+ options = !libtool
+ source = http://lastfmlib.googlecode.com/files/lastfmlib-0.4.0.tar.gz
+ md5sums = f6f00882c15b8cc703718d22e1b1871f
+
+pkgname = lastfmlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233824886342
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+
+pkgname=lastfmlib
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A library that provides an implementation of the Last.fm protocol"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/lastfmlib/"
+license=('GPL')
+depends=('curl')
+options=('!libtool')
+source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('f6f00882c15b8cc703718d22e1b1871f')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+} \ No newline at end of file