summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--latex-mathabx.install13
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87d04b38e121
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = latex-mathabx
+ pkgdesc = Mathematical symbols not included in the standard distribution
+ pkgver = 2005.05.18
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/fonts/mathabx
+ install = latex-mathabx.install
+ arch = any
+ license = unknown
+ depends = texlive-core
+ source = http://mirror.ctan.org/fonts/mathabx.zip
+ md5sums = 82eecbe10d9f5593e01d257523a03c42
+
+pkgname = latex-mathabx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc7feba9d028
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=latex-mathabx
+_pkgname=mathabx
+pkgver=2005.05.18
+pkgrel=1
+pkgdesc="Mathematical symbols not included in the standard distribution"
+arch=('any')
+url="http://www.ctan.org/tex-archive/fonts/mathabx"
+license=('unknown')
+depends=('texlive-core')
+source=("http://mirror.ctan.org/fonts/mathabx.zip")
+install="$pkgname.install"
+md5sums=('82eecbe10d9f5593e01d257523a03c42')
+
+package() {
+ TEXMF="/usr/share/texmf"
+
+ cd "$srcdir/$_pkgname"
+
+ mkdir -p "$pkgdir/$TEXMF/fonts/source/public/mathabx"
+ cp source/*.mf "$pkgdir/$TEXMF/fonts/source/public/mathabx/"
+
+ mkdir -p "$pkgdir/$TEXMF/tex/generic/misc"
+ cp texinputs/* "$pkgdir/$TEXMF/tex/generic/misc/"
+
+ find "$pkgdir" -type d -exec chmod 755 {} \;
+ find "$pkgdir" -type f -exec chmod 644 {} \;
+}
diff --git a/latex-mathabx.install b/latex-mathabx.install
new file mode 100644
index 000000000000..47445e33c217
--- /dev/null
+++ b/latex-mathabx.install
@@ -0,0 +1,13 @@
+post_install() {
+ mktexlsr
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+