summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--MKPKG3
-rw-r--r--PKGBUILD33
-rw-r--r--launchpad-integration.install13
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a46fd582ebd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = launchpad-integration-gtk3
+ pkgdesc = A library to integrate launchpad urls into the menus
+ pkgver = 0.1.56.2
+ pkgrel = 3
+ url = https://launchpad.net/launchpad-integration
+ install = launchpad-integration.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = bzr
+ makedepends = gobject-introspection
+ depends = gtk3
+ depends = pygtk
+ source = launchpad-integration-0.1.56.2.tar.gz::http://bazaar.launchpad.net/~ubuntu-desktop/launchpad-integration/ubuntu/tarball/189
+ sha256sums = SKIP
+
+pkgname = launchpad-integration-gtk3
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..61415704f887
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,3 @@
+pkgname=('launchpad-integration-gtk3')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff421b24013b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=launchpad-integration-gtk3
+pkgver=0.1.56.2
+pkgrel=3
+pkgdesc='A library to integrate launchpad urls into the menus'
+arch=('i686' 'x86_64')
+url="https://launchpad.net/${pkgname%-*}"
+license=('GPL3')
+depends=('gtk3' 'pygtk')
+makedepends=('bzr' 'gobject-introspection')
+install="${pkgname%-*}.install"
+source=("${pkgname%-*}-${pkgver}.tar.gz::http://bazaar.launchpad.net/~ubuntu-desktop/launchpad-integration/ubuntu/tarball/189")
+sha256sums=('SKIP')
+
+build() {
+ cd ~ubuntu-desktop/${pkgname%-*}/ubuntu
+
+ export PYTHON='/usr/bin/python2'
+ ./autogen.sh --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --libexecdir="/usr/lib/${pkgname%-*}" --disable-static --with-gtk='3'
+ make
+}
+
+package() {
+ cd ~ubuntu-desktop/${pkgname%-*}/ubuntu
+
+ make DESTDIR="${pkgdir}" install
+
+# Fix permissions
+ chmod 644 "${pkgdir}"/usr/share/launchpad-integration/launchpadintegration/*
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/launchpad-integration.install b/launchpad-integration.install
new file mode 100644
index 000000000000..44851fff35c3
--- /dev/null
+++ b/launchpad-integration.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -ftq /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: