summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4744e70426e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lausanne-font
+ pkgdesc = A luxury serif typeface borrowing from classic Didot with a hint of Copperplate
+ pkgver = 1.005
+ pkgrel = 1
+ url = https://www.neogrey.com/portfolio/lausanne-free-font
+ arch = any
+ license = custom:FFPU
+ makedepends = hq
+ source = lausanne-1.005.zip::https://dl.dafont.com/dl/?f=lausanne
+ source = font-licenses.html::https://www.neogrey.com/font-licenses
+ sha256sums = 47b9da93f9f34b596cbcf832a04bb3a2285075d9588f0133946f6e38ec3a18f5
+ sha256sums = SKIP
+
+pkgname = otf-lausanne
+ provides = lausanne-font
+
+pkgname = ttf-lausanne
+ provides = lausanne-font
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48562630b35d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_font=lausanne
+pkgbase=$_font-font
+pkgname=("otf-$_font" "ttf-$_font")
+pkgver=1.005
+pkgrel=1
+pkgdesc='A luxury serif typeface borrowing from classic Didot with a hint of Copperplate'
+url="https://www.neogrey.com/portfolio/$_font-free-font"
+arch=('any')
+license=('custom:FFPU')
+makedepends=('hq')
+source=("$_font-$pkgver.zip::https://dl.dafont.com/dl/?f=${_font/-/_}"
+ "font-licenses.html::https://www.neogrey.com/font-licenses")
+sha256sums=('47b9da93f9f34b596cbcf832a04bb3a2285075d9588f0133946f6e38ec3a18f5'
+ 'SKIP')
+
+prepare() {
+ hq article text < font-licenses.html > FFPU.txt
+}
+
+package_otf-lausanne() {
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}
+
+package_ttf-lausanne() {
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}