summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD47
2 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c89959ee29c..3d4be5284827 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = layan-cursor-theme-git
pkgdesc = A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors
pkgver = 0.0.0.7a37de2
- pkgrel = 5
+ pkgrel = 1
+ epoch = 1
url = https://github.com/vinceliuice/Layan-cursors
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 219d0f5b7daf..1f6757bb679c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname="layan-cursor-theme-git"
pkgver=0.0.0.7a37de2
-pkgrel=5
-pkgdesc='A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors'
+pkgrel=1
+epoch=1
+pkgdesc="A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors"
arch=("any")
url="https://github.com/vinceliuice/Layan-cursors"
license=("GPL3")
@@ -15,30 +16,30 @@ b2sums=("SKIP")
pkgver()
{
- cd "Layan-cursors"
- if [ $(git tag|wc -l) == 0 ]; then
- echo "0.0.0.$(git log -1 --format='%h')"
- else
- git describe --tags | sed "s/-/.r/; s/-g/./"
- fi
+ cd "Layan-cursors"
+ if [ "$(git tag|wc -l)" == 0 ]; then
+ echo "0.0.0.$(git log -1 --format='%h')"
+ else
+ git describe --tags | sed "s/-/.r/; s/-g/./"
+ fi
}
package()
{
- if [ -z "${_cleancursordirname+x}" ]; then
- _cleancursordirname=false
- fi
+ if [ -z "${_cleancursordirname+x}" ]; then
+ _cleancursordirname=false
+ fi
- install -d "${pkgdir}/usr/share/icons"
-
- cd "Layan-cursors"
- if [ "$_cleancursordirname" = "true" ]; then
- cp -r "dist" "${dst}/Layan Unraveled"
- cp -r "dist-border" "${dst}/Layan"
- cp -r "dist-white" "${dst}/Layan Reborn"
- else
- cp -r "dist" "${dst}/Layan-cursors"
- cp -r "dist-border" "${dst}/Layan-border-cursors"
- cp -r "dist-white" "${dst}/Layan-white-cursors"
- fi
+ install -d "${pkgdir}/usr/share/icons"
+
+ cd "Layan-cursors"
+ if [ "$_cleancursordirname" = "true" ]; then
+ cp -r "dist" "${pkgdir}/usr/share/icons/Layan Unraveled"
+ cp -r "dist-border" "${pkgdir}/usr/share/icons/Layan"
+ cp -r "dist-white" "${pkgdir}/usr/share/icons/Layan Reborn"
+ else
+ cp -r "dist" "${pkgdir}/usr/share/icons/Layan-cursors"
+ cp -r "dist-border" "${pkgdir}/usr/share/icons/Layan-border-cursors"
+ cp -r "dist-white" "${pkgdir}/usr/share/icons/Layan-white-cursors"
+ fi
}