summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb43cb561572
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = lazygull-engine
+ pkgdesc = A UCI chess engine based on Gull 3
+ pkgver = alpha_0.3
+ pkgrel = 1
+ url = https://github.com/basil00/Gull
+ arch = x86_64
+ license = MIT
+ source = https://github.com/basil00/Gull/archive/LazyGull-alpha-0.3.tar.gz
+ sha256sums = 0d3952fde37bfb6000fdfde71f1fce9d6a15e1d8aa691131630802dcd36889bc
+
+pkgname = lazygull-engine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6d69dd0df59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: archlinux.info:tdy
+
+pkgname=lazygull-engine
+pkgver=alpha_0.3
+pkgrel=1
+pkgdesc="A UCI chess engine based on Gull 3"
+arch=(x86_64)
+url=https://github.com/basil00/Gull
+license=(MIT)
+source=(https://github.com/basil00/Gull/archive/LazyGull-${pkgver/_/-}.tar.gz)
+sha256sums=(0d3952fde37bfb6000fdfde71f1fce9d6a15e1d8aa691131630802dcd36889bc)
+
+build() {
+ cd Gull-LazyGull-${pkgver/_/-}/src
+ make -f Makefile.linux build
+}
+
+package() {
+ cd Gull-LazyGull-${pkgver/_/-}/src
+ install -Dm755 LazyGull "$pkgdir"/usr/bin/LazyGull
+ sed -n 's/^ .[ ]*//; 3,21p' tbprobe.h > LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}