summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdd22fe399b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lazygull-engine-git
+ pkgdesc = A UCI chess engine based on Gull 3
+ pkgver = r28.db77394
+ pkgrel = 1
+ url = https://github.com/basil00/Gull
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/basil00/Gull.git
+ sha256sums = SKIP
+
+pkgname = lazygull-engine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e3764f982df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: archlinux.info:tdy
+
+pkgname=lazygull-engine-git
+pkgver=r28.db77394
+pkgrel=1
+pkgdesc="A UCI chess engine based on Gull 3"
+arch=(x86_64)
+url=https://github.com/basil00/Gull
+license=(MIT)
+makedepends=(git)
+source=(git+https://github.com/basil00/Gull.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd Gull
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Gull/src
+ make -f Makefile.linux build
+}
+
+package() {
+ cd Gull/src
+ install -Dm755 LazyGull "$pkgdir"/usr/bin/LazyGull
+ sed -n 's/^ .[ ]*//; 3,21p' tbprobe.h > LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}