summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--include.patch10
3 files changed, 7 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f599a36b9af2..be2527bad619 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lbrycrd
pkgdesc = Blockchain daemon that provides the digital content namespace for the LBRY protocol
- pkgver = 0.17.3.2
+ pkgver = 0.19.1.3
pkgrel = 1
url = https://lbry.tech
install = lbrycrd.install
@@ -19,14 +19,12 @@ pkgbase = lbrycrd
optdepends = protobuf
optdepends = qrencode
backup = etc/lbrycrd.conf
- source = lbrycrd-0.17.3.2.tar.gz::https://github.com/lbryio/lbrycrd/archive/v0.17.3.2.tar.gz
+ source = lbrycrd-0.19.1.3.tar.gz::https://github.com/lbryio/lbrycrd/archive/v0.19.1.3.tar.gz
source = lbrycrd.service
source = lbrycrd.conf
- source = include.patch
- sha256sums = 1ac547aed45272ad4f5ff557407b804b37fc54b5e0b0bc0addedd2c9cb00a970
+ sha256sums = 4812afef81a2f817509eb196b8ecc5d59333100785506cecf63779750bea330a
sha256sums = d6424f9341ed1b21774fb9341721044cc737e7d633641cb92781773c2b2f77a8
sha256sums = b97c87108220abf125421eef77f12718ffcff75c22765a0933858dcaf547f32c
- sha256sums = a29e666e626cf20df809a689fcb76e0950b7c2fbd6fb41eaccb71de1fbef3c51
pkgname = lbrycrd
diff --git a/PKGBUILD b/PKGBUILD
index 08bab6c89eb8..3984986ad41b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: redfish <redfish@galactica.pw>
pkgname=lbrycrd
-pkgver=0.17.3.2
+pkgver=0.19.1.3
pkgrel=1
pkgdesc='Blockchain daemon that provides the digital content namespace for the LBRY protocol'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -12,16 +12,10 @@ optdepends=('miniupnpc' 'qt5-base' 'protobuf' 'qrencode')
makedepends=('boost')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lbryio/lbrycrd/archive/v${pkgver}.tar.gz"
${pkgname}.service
- ${pkgname}.conf
- include.patch)
+ ${pkgname}.conf)
install=$pkgname.install
backup=("etc/${pkgname}.conf")
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < $srcdir/include.patch
-}
-
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -50,7 +44,6 @@ check() {
src/test/test_lbrycrd
}
-sha256sums=('1ac547aed45272ad4f5ff557407b804b37fc54b5e0b0bc0addedd2c9cb00a970'
+sha256sums=('4812afef81a2f817509eb196b8ecc5d59333100785506cecf63779750bea330a'
'd6424f9341ed1b21774fb9341721044cc737e7d633641cb92781773c2b2f77a8'
- 'b97c87108220abf125421eef77f12718ffcff75c22765a0933858dcaf547f32c'
- 'a29e666e626cf20df809a689fcb76e0950b7c2fbd6fb41eaccb71de1fbef3c51')
+ 'b97c87108220abf125421eef77f12718ffcff75c22765a0933858dcaf547f32c')
diff --git a/include.patch b/include.patch
deleted file mode 100644
index 7d004175ca17..000000000000
--- a/include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/httpserver.cpp 2020-08-22 13:10:15.488497884 -0400
-+++ b/src/httpserver.cpp 2020-08-22 13:10:35.218791399 -0400
-@@ -13,6 +13,7 @@
- #include <sync.h>
- #include <ui_interface.h>
-
-+#include <deque>
- #include <memory>
- #include <stdio.h>
- #include <stdlib.h>