summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rw-r--r--lbrycrd.conf5
-rw-r--r--lbrycrd.service8
5 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54f396ac0d57..f599a36b9af2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,18 +11,21 @@ pkgbase = lbrycrd
license = MIT
makedepends = boost
depends = boost-libs
- depends = db4.8
+ depends = db
depends = libevent
depends = openssl
optdepends = miniupnpc
optdepends = qt5-base
optdepends = protobuf
optdepends = qrencode
+ backup = etc/lbrycrd.conf
source = lbrycrd-0.17.3.2.tar.gz::https://github.com/lbryio/lbrycrd/archive/v0.17.3.2.tar.gz
source = lbrycrd.service
+ source = lbrycrd.conf
source = include.patch
sha256sums = 1ac547aed45272ad4f5ff557407b804b37fc54b5e0b0bc0addedd2c9cb00a970
- sha256sums = ce31e5a787cafe6591f8c987049f93ea9417bc37ec48fa11dc5e521942d1f333
+ sha256sums = d6424f9341ed1b21774fb9341721044cc737e7d633641cb92781773c2b2f77a8
+ sha256sums = b97c87108220abf125421eef77f12718ffcff75c22765a0933858dcaf547f32c
sha256sums = a29e666e626cf20df809a689fcb76e0950b7c2fbd6fb41eaccb71de1fbef3c51
pkgname = lbrycrd
diff --git a/.gitignore b/.gitignore
index f915aa3c6776..9ff8614b0b10 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pkg.tar.zst
+*.pkg.tar.xz
*.tar.gz
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index d147ffea884d..08bab6c89eb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,15 @@ pkgdesc='Blockchain daemon that provides the digital content namespace for the L
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://lbry.tech"
license=('MIT')
-depends=('boost-libs' 'db4.8' 'libevent' 'openssl')
+depends=('boost-libs' 'db' 'libevent' 'openssl') # db4.8 does not build for aarch64
optdepends=('miniupnpc' 'qt5-base' 'protobuf' 'qrencode')
makedepends=('boost')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lbryio/lbrycrd/archive/v${pkgver}.tar.gz"
${pkgname}.service
+ ${pkgname}.conf
include.patch)
install=$pkgname.install
+backup=("etc/${pkgname}.conf")
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -24,7 +26,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
./autogen.sh
- ./configure --prefix=/usr --without-gui
+ ./configure --prefix=/usr --without-gui --with-incompatible-bdb
make
}
@@ -49,5 +51,6 @@ check() {
}
sha256sums=('1ac547aed45272ad4f5ff557407b804b37fc54b5e0b0bc0addedd2c9cb00a970'
- 'ce31e5a787cafe6591f8c987049f93ea9417bc37ec48fa11dc5e521942d1f333'
+ 'd6424f9341ed1b21774fb9341721044cc737e7d633641cb92781773c2b2f77a8'
+ 'b97c87108220abf125421eef77f12718ffcff75c22765a0933858dcaf547f32c'
'a29e666e626cf20df809a689fcb76e0950b7c2fbd6fb41eaccb71de1fbef3c51')
diff --git a/lbrycrd.conf b/lbrycrd.conf
new file mode 100644
index 000000000000..bce576e1a9b1
--- /dev/null
+++ b/lbrycrd.conf
@@ -0,0 +1,5 @@
+# For all available options, see: lbrycrdd -help
+
+server=1
+daemon=1
+datadir=/var/lib/lbrycrd
diff --git a/lbrycrd.service b/lbrycrd.service
index e79683579153..a3008ace5fe7 100644
--- a/lbrycrd.service
+++ b/lbrycrd.service
@@ -5,8 +5,12 @@ Description=Blockchain daemon for LBRY
User=lbrycrd
Group=lbrycrd
#WorkingDirectory=/var/lib/lbrycrd
-ExecStart=/usr/bin/lbrycrdd -server
-#SyslogIdentifier=zeronet
+RuntimeDirectory=lbrycrd
+RuntimeDirectoryMode=0700
+Type=forking
+ExecStart=/usr/bin/lbrycrdd -conf=/etc/lbrycrd.conf -pid=/run/lbrycrd/lbrycrd.pid
+PIDFile=/run/lbrycrd/lbrycrd.pid
+#SyslogIdentifier=lbrycrd
#Restart=on-failure
[Install]