summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed36370a607c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Sep 20 23:27:40 UTC 2016
+pkgbase = lcov-git
+ pkgdesc = Latest snapshot of lcov, a front-end for GCC's coverage testing tool gcov
+ pkgver = r285.68320d9
+ pkgrel = 1
+ url = http://ltp.sourceforge.net/coverage/lcov.php
+ arch = any
+ license = GPL
+ depends = perl
+ conflicts = lcov
+ source = git://github.com/linux-test-project/lcov.git
+ md5sums = SKIP
+
+pkgname = lcov-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce06a9bc9e91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
+#
+# This package does not contain any patches. Its main purpose
+# is to simplify testing against the latest upstream version.
+#
+# Unless you have a reason to use the snapshot version,
+# you should probably just stick with the aur/lcov package.
+#
+pkgname=lcov-git
+pkgver=r285.68320d9
+pkgrel=1
+pkgdesc="Latest snapshot of lcov, a front-end for GCC's coverage testing tool gcov"
+arch=('any')
+url="http://ltp.sourceforge.net/coverage/lcov.php"
+license=('GPL')
+depends=('perl')
+conflicts=('lcov')
+source=('git://github.com/linux-test-project/lcov.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd lcov
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/lcov"
+ make PREFIX="$pkgdir" install
+
+ # fix namcap warnings about non-standard directories
+ mkdir -p "$pkgdir/usr"
+ test -d "$pkgdir/usr/bin" || mv "$pkgdir/bin" "$pkgdir/usr/bin"
+ test -d "$pkgdir/usr/share" || mv "$pkgdir/share" "$pkgdir/usr/share"
+}