summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e1b728d2f92..08b6dd457718 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Apr 6 13:25:46 UTC 2018
+# Thu Sep 26 09:41:38 UTC 2019
pkgbase = ldfpcfix
- pkgdesc = Binary patch /usr/bin/ld to quiet the "contains output sections" warning that appears when compiling with fpc
+ pkgdesc = Silence the "contains output sections" warning from /usr/bin/ld
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/xyproto/ldfpcfix
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 418525b49b9f..34505cd30557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,22 @@
pkgname=ldfpcfix
pkgver=1.0
-pkgrel=3
-pkgdesc='Binary patch /usr/bin/ld to quiet the "contains output sections" warning that appears when compiling with fpc'
-arch=('any')
+pkgrel=4
+pkgdesc='Silence the "contains output sections" warning from /usr/bin/ld'
+arch=(any)
url='https://github.com/xyproto/ldfpcfix'
license=('MIT')
-makedepends=('go' 'git')
+makedepends=(go git)
source=("git+https://github.com/xyproto/ldfpcfix#tag=v$pkgver")
-sha256sums=('SKIP')
+sha256sums=(SKIP)
build() {
- cd "$pkgname"
-
+ cd $pkgname
go build
}
package() {
- install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
}
# vim: ts=2 sw=2 et: