summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD60
-rw-r--r--leaderf-neovim-doc.hook11
-rw-r--r--leaderf-vim-doc.hook11
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8e6765860bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = leaderf-git
+ pkgdesc = An efficient fuzzy finder that helps to locate files, buffers, mrus, gtags, etc. on the fly for both vim and neovim.
+ pkgver = v1.22.r48.g312a13b
+ pkgrel = 1
+ url = https://github.com/Yggdroot/LeaderF
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python
+ source = leaderf::git+https://github.com/Yggdroot/LeaderF.git
+ source = leaderf-vim-doc.hook
+ source = leaderf-neovim-doc.hook
+ sha256sums = SKIP
+ sha256sums = d125b79fe4f7e6d205010a96acf78ac63814c26d98050a46f8e627993ff033ea
+ sha256sums = 05c97e2b6bea21bf573ac89ec226c640041c65afd12bfcc4954f42ed39d8df41
+
+pkgname = vim-leaderf-git
+ depends = vim
+ depends = python
+ provides = vim-leaderf
+ conflicts = vim-leaderf
+
+pkgname = neovim-leaderf-git
+ depends = neovim
+ depends = python-pynvim
+ provides = neovim-leaderf
+ conflicts = neovim-leaderf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..831a03869e12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgbase=leaderf-git
+pkgname=('vim-leaderf-git'
+ 'neovim-leaderf-git')
+_pkgname=leaderf
+pkgver=v1.22.r48.g312a13b
+pkgrel=1
+pkgdesc='An efficient fuzzy finder that helps to locate files, buffers, mrus, gtags, etc. on the fly for both vim and neovim.'
+arch=('any')
+url='https://github.com/Yggdroot/LeaderF'
+license=('Apache')
+source=("${_pkgname}::git+https://github.com/Yggdroot/LeaderF.git"
+ "${_pkgname}-vim-doc.hook"
+ "${_pkgname}-neovim-doc.hook")
+sha256sums=('SKIP'
+ 'd125b79fe4f7e6d205010a96acf78ac63814c26d98050a46f8e627993ff033ea'
+ '05c97e2b6bea21bf573ac89ec226c640041c65afd12bfcc4954f42ed39d8df41')
+makedepends=('git'
+ 'python')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ bash install.sh
+ touch doc/tags
+}
+
+package_vim-leaderf-git() {
+ depends=('vim' 'python')
+ provides=('vim-leaderf')
+ conflicts=('vim-leaderf')
+ _packdir="usr/share/vim/vimfiles/pack/${_pkgname}/start/${_pkgname}"
+ _variant='vim'
+
+ cd "${srcdir}/${_pkgname}"
+ find autoload doc plugin syntax -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
+}
+
+package_neovim-leaderf-git() {
+ depends=('neovim' 'python-pynvim')
+ provides=('neovim-leaderf')
+ conflicts=('neovim-leaderf')
+ _packdir="usr/share/nvim/runtime/pack/${_pkgname}/start/${_pkgname}"
+ _variant='neovim'
+
+ cd "${srcdir}/${_pkgname}"
+ find autoload doc plugin syntax -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
+}
diff --git a/leaderf-neovim-doc.hook b/leaderf-neovim-doc.hook
new file mode 100644
index 000000000000..bcd8ff371264
--- /dev/null
+++ b/leaderf-neovim-doc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/share/nvim/runtime/pack/leaderf/start/leaderf/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/nvim -es --cmd ":helptags /usr/share/nvim/runtime/pack/leaderf/start/leaderf/doc" --cmd ":q"
+When = PostTransaction
diff --git a/leaderf-vim-doc.hook b/leaderf-vim-doc.hook
new file mode 100644
index 000000000000..63f0d0a4cad7
--- /dev/null
+++ b/leaderf-vim-doc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/share/vim/vimfiles/pack/leaderf/start/leaderf/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/pack/leaderf/start/leaderf/doc" --cmd ":q"
+When = PostTransaction