summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca95710371f0..cea8133b3ca9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = legacyfox
pkgdesc = Legacy bootstrapped extensions for Firefox 65 and beyond
- pkgver = 2.0
+ pkgver = 2.2
pkgrel = 1
url = https://gir.st/blog/legacyfox.htm
arch = any
license = MPL
- makedepends = git
depends = firefox
- noextract = legacyfox.tar.gz
- source = https://github.com/girst/LegacyFox/releases/download/v2.0/legacyfox.tar.gz
- sha256sums = 44ce5bca375e92e1d7ec58a78326deac3e67ac044b42e40892f5b18087e0c95b
+ source = https://git.gir.st/LegacyFox.git/snapshot/v2.2.tar.gz
+ sha256sums = 19306101a5d0a973e2b0913250678dadc932432db70c56eaa443748e23825d58
pkgname = legacyfox
diff --git a/PKGBUILD b/PKGBUILD
index 253d839e3859..e8523aafee1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
# Maintainer: neeshy <neeshy@tfwno.gf>
pkgname=legacyfox
-pkgver=2.0
+pkgver=2.2
pkgrel=1
pkgdesc="Legacy bootstrapped extensions for Firefox 65 and beyond"
arch=('any')
url="https://gir.st/blog/legacyfox.htm"
license=('MPL')
depends=('firefox')
-makedepends=('git')
-source=("https://github.com/girst/LegacyFox/releases/download/v$pkgver/$pkgname.tar.gz")
-noextract=("$pkgname.tar.gz")
-sha256sums=('44ce5bca375e92e1d7ec58a78326deac3e67ac044b42e40892f5b18087e0c95b')
+_commit=022cf6d
+source=("https://git.gir.st/LegacyFox.git/snapshot/v$pkgver.tar.gz")
+sha256sums=('19306101a5d0a973e2b0913250678dadc932432db70c56eaa443748e23825d58')
package() {
- cd "$srcdir"
- install -d "$pkgdir/usr/lib/firefox"
- tar xzf "$pkgname.tar.gz" -C "$pkgdir/usr/lib/firefox"
+ cd "$srcdir/LegacyFox-v$pkgver-$_commit"
+ install -Dm644 -t "$pkgdir/usr/lib/firefox" config.js legacy.manifest
+ install -Dm644 defaults/pref/config-prefs.js "$pkgdir/usr/lib/firefox/defaults/pref/config-prefs.js"
+ install -Dm644 legacy/BootstrapLoader.jsm "$pkgdir/usr/lib/firefox/legacy/BootstrapLoader.jsm"
+ install -Dm644 legacy/RDFDataSource.jsm "$pkgdir/usr/lib/firefox/legacy/RDFDataSource.jsm"
+ install -Dm644 legacy/RDFManifestConverter.jsm "$pkgdir/usr/lib/legacy/RDFManifestConverter.jsm"
}