summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD34
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4b4fc529a1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = legendofdungeon
+ pkgdesc = A 4 Player Co-op Rogue-Like-like Beat'em'up with Dynamic Lighting on AWESOME Pixel Art.
+ pkgver = Unicorn
+ pkgrel = 1
+ url = http://www.robotloveskitty.com/LoD/
+ arch = x86_64
+ license = custom
+ depends = lib32-libxdmcp
+ depends = lib32-libxau
+ depends = lib32-libxrender
+ depends = lib32-libdrm
+ depends = lib32-libxxf86vm
+ depends = lib32-libxshmfence
+ depends = lib32-libxcb
+ depends = lib32-libx11
+ depends = lib32-libxfixes
+ depends = lib32-libxdamage
+ depends = lib32-mesa
+ depends = lib32-expat
+ depends = lib32-glibc
+ depends = lib32-gcc-libs
+ depends = lib32-glibc
+ depends = lib32-libxcursor
+ depends = lib32-libxext
+ depends = lib32-libx11
+ depends = lib32-mesa-libgl
+ depends = lib32-glu
+ depends = lib32-gcc-libs
+ source = LegendofDungeon-Linux-Unicorn.zip::https://manual-download-required
+ md5sums = 87c9099e06a446b8159454b9a03a5912
+
+pkgname = legendofdungeon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f2823721f30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+# Since you need to purchase this game, you'll need to place the zip
+# file provided in the same directory as this PKGBUILD in order to build
+# this package.
+
+pkgname=legendofdungeon
+pkgver=Unicorn
+pkgrel=1
+pkgdesc="A 4 Player Co-op Rogue-Like-like Beat'em'up with Dynamic Lighting on AWESOME Pixel Art."
+group=("games")
+arch=("x86_64")
+url="http://www.robotloveskitty.com/LoD/"
+license=('custom')
+depends=(lib32-libxdmcp lib32-libxau lib32-libxrender lib32-libdrm
+ lib32-libxxf86vm lib32-libxshmfence lib32-libxcb lib32-libx11
+ lib32-libxfixes lib32-libxdamage lib32-mesa lib32-expat lib32-glibc
+ lib32-gcc-libs lib32-glibc lib32-libxcursor lib32-libxext lib32-libx11
+ lib32-mesa-libgl lib32-glu lib32-gcc-libs)
+source=(LegendofDungeon-Linux-${pkgver}.zip::https://manual-download-required)
+md5sums=('87c9099e06a446b8159454b9a03a5912')
+PKGEXT=".pkg.tar"
+
+package() {
+ cd "$srcdir/LegendofDungeon-Linux"
+
+ install -Dm 755 LegendofDungeon.x86 "${pkgdir}/opt/LegendofDungeon/LegendofDungeon"
+
+ find LegendofDungeon_Data -type f -exec \
+ install -Dm 644 {} "${pkgdir}/opt/LegendofDungeon/{}" \;
+
+ install -d "${pkgdir}/usr/bin/"
+ ln -s "/opt/LegendofDungeon/LegendofDungeon" "${pkgdir}/usr/bin/legendofdungeon"
+}