summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rwxr-xr-xstartbt.sh10
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5e3937ae72c..43ca6db0162f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = lenovo-s20-30
pkgdesc = Configuration to support netbook Lenovo S20-30
- pkgver = 0.1.1
- pkgrel = 3
+ pkgver = 0.1.2
+ pkgrel = 1
url = https://bitbucket.org/raimar/lenovo-s20-30
install = install
arch = any
license = GPL2
source = lenovo_s20-30_blacklist.conf
source = lenovo_s20-30_load.conf
+ source = startbt.sh
sha256sums = 3451688ddadac8699546e68f41607a7436dd8e25f1c6e0fc5989561b07b526b5
sha256sums = 0176afe92b990be5ca9145f14504ee8d1ae8349a9f3cd9d7f0ddaade6ebe59e5
+ sha256sums = d00a6601d4d137b246fbca6f1b9848552370af256182ac5f17c898f026db1f3b
pkgname = lenovo-s20-30
diff --git a/PKGBUILD b/PKGBUILD
index 975a4ee679a8..17aeccc528a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Raimar Buehmann <raimar _at_ buehmann _dot_ de>
pkgname=lenovo-s20-30
-pkgver=0.1.1
-pkgrel=3
+pkgver=0.1.2
+pkgrel=1
pkgdesc='Configuration to support netbook Lenovo S20-30'
url='https://bitbucket.org/raimar/lenovo-s20-30'
arch=(any)
@@ -10,13 +10,16 @@ license=('GPL2')
source=(
lenovo_s20-30_blacklist.conf
lenovo_s20-30_load.conf
+ startbt.sh
)
sha256sums=('3451688ddadac8699546e68f41607a7436dd8e25f1c6e0fc5989561b07b526b5'
- '0176afe92b990be5ca9145f14504ee8d1ae8349a9f3cd9d7f0ddaade6ebe59e5')
+ '0176afe92b990be5ca9145f14504ee8d1ae8349a9f3cd9d7f0ddaade6ebe59e5'
+ 'd00a6601d4d137b246fbca6f1b9848552370af256182ac5f17c898f026db1f3b')
install=install
package() {
install -Dm644 lenovo_s20-30_blacklist.conf "${pkgdir}/usr/lib/modprobe.d/lenovo_s20-30_blacklist.conf"
install -Dm644 lenovo_s20-30_load.conf "${pkgdir}/usr/lib/modules-load.d/lenovo_s20-30_load.conf"
+ install -Dm744 startbt.sh "${pkgdir}/usr/bin/startbt.sh"
}
diff --git a/startbt.sh b/startbt.sh
new file mode 100755
index 000000000000..d2eed4b7e4e0
--- /dev/null
+++ b/startbt.sh
@@ -0,0 +1,10 @@
+#!/usr/bin/bash
+# manually start the bluetooth device BCM43142A0
+
+# set the vendor and product ID
+echo "105b e065" > /sys/bus/usb/drivers/btusb/new_id
+
+# start the device
+hciconfig hci0 up
+
+# the device can be stopped with "sudo hciconfig hci0 down"