summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--Makefile21
-rw-r--r--PKGBUILD9
3 files changed, 33 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dad23c17365f..1f6281ebe597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = lesana-git
pkgdesc = Manage collection inventories throught yaml files, develop version
- pkgver = v0.8.1.r22.gfea348c
+ pkgver = v0.9.1.r18.g744139f
pkgrel = 1
url = https://lesana.trueelena.org/
- arch = x86_64
- arch = aarch64
+ arch = any
license = GPL3
+ makedepends = git
makedepends = python-setuptools
depends = python-dateutil
depends = python-jinja
depends = python-ruamel-yaml
depends = python-xapian
- depends = python-gitpython
+ depends = python-setuptools
+ depends = python-hazwaz
+ optdepends = python-argcomplete: enable commandline tab completion
+ optdepends = python-gitpython: git integration
provides = lesana
conflicts = lesana
source = git+https://git.sr.ht/~valhalla/lesana
md5sums = SKIP
pkgname = lesana-git
-
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..bdfd498f482e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+.PHONY: all build push clean
+
+all: .SRCINFO
+ git add PKGBUILD .SRCINFO
+
+.SRCINFO: PKGBUILD
+ namcap PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+build:
+ makepkg -f
+ namcap *.pkg.tar.zst
+
+push: build .SRCINFO
+ git add PKGBUILD .SRCINFO
+ git commit
+ git push
+
+clean:
+ rm -f *.pkg.tar.zst
+ rm -fr pkg src
diff --git a/PKGBUILD b/PKGBUILD
index 76a6634deb86..48cdca4eb7aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
_pkgname=lesana
pkgname=lesana-git
-pkgver=v0.8.1.r22.gfea348c
+pkgver=v0.9.1.r18.g744139f
pkgrel=1
pkgdesc="Manage collection inventories throught yaml files, develop version"
-arch=('x86_64' 'aarch64')
+arch=('any')
url="https://lesana.trueelena.org/"
license=(GPL3)
-depends=('python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-gitpython')
-makedepends=('python-setuptools')
+depends=('python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-setuptools' 'python-hazwaz')
+optdepends=('python-argcomplete: enable commandline tab completion' 'python-gitpython: git integration')
+makedepends=('git' 'python-setuptools')
provides=(lesana)
conflicts=(lesana)
source=("git+https://git.sr.ht/~valhalla/lesana")