summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--lfp.install11
3 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98d0245266f5..6b84aefd9c8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lfp
pkgdesc = A wrapper for the lf file manager with in-terminal media previews, on-exit directory changing and much more
- pkgver = 4.1.0
+ pkgver = 4.1.1
pkgrel = 1
url = https://gitlab.com/a4to/lfp
install = lfp.install
@@ -27,9 +27,9 @@ pkgbase = lfp
optdepends = nodejs: to make use of lfps built in node actions manager
optdepends = python3: to make use of lfps built in python actions manager
conflicts = lfp-git
- source = https://software.concise.cc/x86_64/lfp-4.1.0-1-x86_64.pkg.tar.xz
+ source = https://software.concise.cc/x86_64/lfp-4.1.1-1-x86_64.pkg.tar.xz
validpgpkeys = 81BACEEBC3EA26E127166E4A819BB92A9A48160E
- md5sums = 1e3ee5da82c783a5d998abe41bd72b29
- sha512sums = d7566d3bf49ec7b4a73f4550bad8050de944a0ca9fe07421fbde9f970f4ab0bb244f4bd224ff7067c87b803a512a700f063e82924cd04bfaed6bd254d17db7f1
+ md5sums = 3afac974ae6c28b9cbde9bfef3917257
+ sha512sums = bb4b8dda8c7e6fcd0f182b0ee817d6151d9d37053a4d032e3986c3d432e550081630e7e0dff81257a8dd2308b47a8ed0875f4ff895956040f04d697bcde38a97
pkgname = lfp
diff --git a/PKGBUILD b/PKGBUILD
index 3596f76d0916..ce934f6f84ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Connor Etherington <connor@concise.cc>
# ---
pkgname=lfp
-pkgver=4.1.0
+pkgver=4.1.1
pkgrel=1
pkgdesc='A wrapper for the lf file manager with in-terminal media previews, on-exit directory changing and much more'
license=('MIT')
@@ -18,10 +18,10 @@ source=(
"https://software.concise.cc/x86_64/${pkgname}-${pkgver}-${pkgrel}-$arch.pkg.tar.xz"
)
sha512sums=(
- 'd7566d3bf49ec7b4a73f4550bad8050de944a0ca9fe07421fbde9f970f4ab0bb244f4bd224ff7067c87b803a512a700f063e82924cd04bfaed6bd254d17db7f1'
+ 'bb4b8dda8c7e6fcd0f182b0ee817d6151d9d37053a4d032e3986c3d432e550081630e7e0dff81257a8dd2308b47a8ed0875f4ff895956040f04d697bcde38a97'
)
md5sums=(
- '1e3ee5da82c783a5d998abe41bd72b29'
+ '3afac974ae6c28b9cbde9bfef3917257'
)
validpgpkeys=(
'81BACEEBC3EA26E127166E4A819BB92A9A48160E'
diff --git a/lfp.install b/lfp.install
index 6c915df2dc95..dd88f474df05 100644
--- a/lfp.install
+++ b/lfp.install
@@ -1,9 +1,14 @@
+install(){
+ which yarn >/dev/null 2>&1 && yarn install /usr/share/lfp/ocr ||
+ which npm >/dev/null 2>&1 && npm install /usr/share/lfp/ocr ||
+ true
+}
+
post_install() {
+ install
echo -e "\n \033[1;33m[+]\e[0;1;32m For on-exit directory changing, add the following line to your bash/zshrc\e[0m :\e[36m\n\n source '/usr/share/lfp/lfpcd'\n\n\n\e[0m"
}
post_upgrade() {
- which yarn >/dev/null 2>&1 && yarn install /usr/share/lfp/ocr ||
- which npm >/dev/null 2>&1 && npm install /usr/share/lfp/ocr ||
- true
+ install
}