summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--a52dec-0.7.4-build.patch27
-rw-r--r--stderr.patch17
4 files changed, 10 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8732123611ca..c3c713af1e2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
pkgbase = lib32-a52dec
pkgdesc = A free library for decoding ATSC A/52 streams (32-bit)
- pkgver = 0.7.4
- pkgrel = 10
- url = https://liba52.sourceforge.io/
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://git.adelielinux.org/community/a52dec/
arch = x86_64
license = GPL2
depends = lib32-glibc
depends = a52dec
- source = http://liba52.sourceforge.net/files/a52dec-0.7.4.tar.gz
- source = a52dec-0.7.4-build.patch
- source = stderr.patch
- md5sums = caa9f5bc44232dc8aeea773fea56be80
- md5sums = fa16f224a7dceb7613824380abef0052
- md5sums = 52f57e003259a24516eaab08b64ae703
+ source = https://distfiles.adelielinux.org/source/a52dec/a52dec-0.8.0.tar.gz
+ sha256sums = 03c181ce9c3fe0d2f5130de18dab9bd8bc63c354071515aa56983c74a9cffcc9
pkgname = lib32-a52dec
-
diff --git a/PKGBUILD b/PKGBUILD
index 1973baa85785..d105f5d6c6ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,15 @@
_basename=a52dec
pkgname=lib32-a52dec
-pkgver=0.7.4
-pkgrel=10
+pkgver=0.8.0
+pkgrel=1
pkgdesc="A free library for decoding ATSC A/52 streams (32-bit)"
-url="https://liba52.sourceforge.io/"
+url="https://git.adelielinux.org/community/a52dec/"
arch=('x86_64')
license=('GPL2')
depends=('lib32-glibc' a52dec)
-source=("http://liba52.sourceforge.net/files/${_basename}-${pkgver}.tar.gz"
- 'a52dec-0.7.4-build.patch'
- 'stderr.patch')
-md5sums=('caa9f5bc44232dc8aeea773fea56be80'
- 'fa16f224a7dceb7613824380abef0052'
- '52f57e003259a24516eaab08b64ae703')
-
-prepare() {
- cd "${_basename}-${pkgver}"
-
- patch -Np1 -i ../a52dec-0.7.4-build.patch
- patch -Np1 -i ../stderr.patch
- sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in
- mv configure.in configure.ac
-
- ./bootstrap
-}
+source=(https://distfiles.adelielinux.org/source/$_basename/$_basename-$pkgver.tar.gz)
+sha256sums=('03c181ce9c3fe0d2f5130de18dab9bd8bc63c354071515aa56983c74a9cffcc9')
build() {
cd ${_basename}-${pkgver}
diff --git a/a52dec-0.7.4-build.patch b/a52dec-0.7.4-build.patch
deleted file mode 100644
index f3a29f303ceb..000000000000
--- a/a52dec-0.7.4-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Naur a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am
---- a52dec-0.7.4.orig/liba52/Makefile.am 2002-01-27 20:36:48.000000000 -0800
-+++ a52dec-0.7.4/liba52/Makefile.am 2004-11-05 01:10:21.317401872 -0800
-@@ -1,4 +1,3 @@
--CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
-
- lib_LTLIBRARIES = liba52.la
-
-diff -Naur a52dec-0.7.4.orig/liba52/configure.incl a52dec-0.7.4/liba52/configure.incl
---- a52dec-0.7.4.orig/liba52/configure.incl 2002-01-27 20:36:48.000000000 -0800
-+++ a52dec-0.7.4/liba52/configure.incl 2004-11-05 01:11:38.172672216 -0800
-@@ -2,7 +2,6 @@
- AC_SUBST([LIBA52_LIBS])
-
- dnl avoid -fPIC when possible
--LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic"
-
- AC_ARG_ENABLE([double],
- [ --enable-double use double-precision samples])
-diff -Naur a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am
---- a52dec-0.7.4.orig/src/Makefile.am 2002-06-22 18:51:57.000000000 -0700
-+++ a52dec-0.7.4/src/Makefile.am 2004-11-05 01:10:21.320401375 -0800
-@@ -1,4 +1,3 @@
--CFLAGS = @A52DEC_CFLAGS@
-
- bin_PROGRAMS = a52dec extract_a52
- a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c
diff --git a/stderr.patch b/stderr.patch
deleted file mode 100644
index 3459d649d34c..000000000000
--- a/stderr.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -aur a52dec-0.7.4.orig/liba52/imdct.c a52dec-0.7.4/liba52/imdct.c
---- a52dec-0.7.4.orig/liba52/imdct.c 2016-06-10 02:39:52.984345055 -0700
-+++ a52dec-0.7.4/liba52/imdct.c 2016-06-10 02:41:08.304633486 -0700
-@@ -419,13 +419,11 @@
-
- #ifdef LIBA52_DJBFFT
- if (mm_accel & MM_ACCEL_DJBFFT) {
-- fprintf (stderr, "Using djbfft for IMDCT transform\n");
- ifft128 = (void (*) (complex_t *)) fftc4_un128;
- ifft64 = (void (*) (complex_t *)) fftc4_un64;
- } else
- #endif
- {
-- fprintf (stderr, "No accelerated IMDCT transform found\n");
- ifft128 = ifft128_c;
- ifft64 = ifft64_c;
- }