summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Avoid-ambiguity-in-div-invocation.patch23
-rw-r--r--PKGBUILD41
-rw-r--r--fix-lib32-makefile.patch38
-rw-r--r--lib32_caps.patch53
5 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e6067df14bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-caps
+ pkgdesc = The C* Audio Plugin Suite (32 bit)
+ pkgver = 0.9.24
+ pkgrel = 2
+ url = http://quitte.de/dsp/caps.html
+ arch = x86_64
+ groups = ladspa-plugins
+ license = GPL3
+ depends = lib32-gcc-libs
+ depends = lib32-ladspa
+ optdepends = python2: optional CFLAGS check
+ source = http://quitte.de/dsp/caps_0.9.24.tar.bz2
+ source = lib32_caps.patch
+ source = 0001-Avoid-ambiguity-in-div-invocation.patch
+ sha256sums = SKIP
+ sha256sums = 0c57f76795f9a69c042cf750c229fd1e2011c64b56416184949e422da9257037
+ sha256sums = 5e71875dd8976efede46a3e0aa08ccf14a25a838454e1ae2473c4eed7c5937ac
+
+pkgname = lib32-caps
+
diff --git a/0001-Avoid-ambiguity-in-div-invocation.patch b/0001-Avoid-ambiguity-in-div-invocation.patch
new file mode 100644
index 000000000000..32de7c4dee4e
--- /dev/null
+++ b/0001-Avoid-ambiguity-in-div-invocation.patch
@@ -0,0 +1,23 @@
+From: Felipe Sateler <fsateler@debian.org>
+Date: Fri, 1 Jul 2016 19:06:31 -0400
+Subject: Avoid ambiguity in div invocation
+
+Be specific and use int version.
+Fixes build failure with gcc >= 6
+---
+ AutoFilter.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/AutoFilter.cc b/AutoFilter.cc
+index fc087d0..bd6b12f 100644
+--- a/AutoFilter.cc
++++ b/AutoFilter.cc
+@@ -69,7 +69,7 @@ AutoFilter::activate()
+ void
+ AutoFilter::cycle (uint frames)
+ {
+- div_t qr = div (frames, blocksize);
++ div_t qr = div ((int)frames, (int)blocksize);
+ int blocks = qr.quot;
+ if (qr.rem) ++blocks;
+ double over_blocks = 1./blocks;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..463b6938806f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Pulshen Sudokamikaze <pulshencode@outlook.com>
+
+_pkgbasename=caps
+pkgname=lib32-${_pkgbasename}
+pkgver=0.9.24
+pkgrel=2
+pkgdesc="The C* Audio Plugin Suite (32 bit)"
+arch=('x86_64')
+url="http://quitte.de/dsp/caps.html"
+license=('GPL3')
+groups=('ladspa-plugins')
+depends=('lib32-gcc-libs' 'lib32-ladspa')
+optdepends=('python2: optional CFLAGS check')
+source=(http://quitte.de/dsp/${_pkgbasename}_${pkgver}.tar.bz2
+ 'lib32_caps.patch'
+ '0001-Avoid-ambiguity-in-div-invocation.patch')
+sha256sums=('SKIP'
+ '0c57f76795f9a69c042cf750c229fd1e2011c64b56416184949e422da9257037'
+ '5e71875dd8976efede46a3e0aa08ccf14a25a838454e1ae2473c4eed7c5937ac')
+
+prepare() {
+ cd $_pkgbasename-$pkgver
+ # use a minimum of optimization required to build
+ export _CFLAGS='-msse -mfpmath=sse'
+}
+
+
+build() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ type -p python2 1>/dev/null && python2 configure.py
+ patch < "${srcdir}/lib32_caps.patch"
+ patch < "${srcdir}/0001-Avoid-ambiguity-in-div-invocation.patch"
+ make
+ }
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ install -v -m 0755 -D caps.so ${pkgdir}/usr/lib32/ladspa/caps.so
+}
diff --git a/fix-lib32-makefile.patch b/fix-lib32-makefile.patch
new file mode 100644
index 000000000000..cc1c7b57ba3e
--- /dev/null
+++ b/fix-lib32-makefile.patch
@@ -0,0 +1,38 @@
+diff --git a/Makefile b/Makefile
+index 0f87e02..a6da26b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+-PREFIX = /usr/local
++PREFIX = /usr
+
+-CC = g++
++CC = g++ -m32
+
+ # only use -ffast-math if you're feeling mighty adventurous. (g++ issues)
+ OPTS = -O2 -funroll-loops -Wall -fPIC -DPIC
+ #OPTS = -g -DDEBUG
+
+-_LDFLAGS = -nostartfiles -shared
++_LDFLAGS = -nostartfiles -shared -L/usr/lib32
+ STRIP = strip
+
+ -include defines.make
+@@ -23,7 +23,7 @@ HEADERS = $(wildcard *.h) $(wildcard dsp/*.h) $(wildcard util/*.h) $(wildcard ds
+
+ PDF = releases/caps-$(VERSION).pdf
+
+-DEST = $(PREFIX)/lib/ladspa
++DEST = $(PREFIX)/lib32/ladspa
+ RDFDEST = $(PREFIX)/share/ladspa/rdf
+
+ # all systems go -------------------------------------------------------------
+@@ -66,8 +66,6 @@ install: all
+ @$(STRIP) $(PLUG).so > /dev/null
+ install -d $(DEST)
+ install -m 644 $(PLUG).so $(DEST)
+- install -d $(RDFDEST)
+- install -m 644 $(PLUG).rdf $(RDFDEST)
+
+ fake-install: all
+ -rm $(DEST)/$(PLUG).so
diff --git a/lib32_caps.patch b/lib32_caps.patch
new file mode 100644
index 000000000000..66615e797c2d
--- /dev/null
+++ b/lib32_caps.patch
@@ -0,0 +1,53 @@
+--- src/caps-0.9.24/Makefile 2016-04-22 22:02:52.547908324 +0300
++++ Makefile 2016-04-22 22:17:53.664602351 +0300
+@@ -1,14 +1,14 @@
+ VERSION = 0.9.24
+
+ PREFIX = /usr
+-DESTDIR =
++DESTDIR =
+
+-CC = g++
++CC = g++ -m32
+
+-OPTS = -O3 -ffast-math -funroll-loops -Wall -fPIC -DPIC
+-#OPTS = -g -DDEBUG
++OPTS = -O2 -ffast-math -funroll-loops -Wall -fPIC -DPIC
++#OPTS = -g -DDEBUG
+
+-_LDFLAGS = -shared
++_LDFLAGS = -nostartfiles -shared -L/usr/lib32
+ STRIP = strip
+
+ -include defines.make
+@@ -19,7 +19,7 @@
+ PLUG = caps
+
+ SOURCES = $(wildcard *.cc) $(wildcard dsp/*.cc)
+-OBJECTS = $(SOURCES:.cc=.o)
++OBJECTS = $(SOURCES:.cc=.o)
+ HEADERS = $(wildcard *.h) $(wildcard dsp/*.h) $(wildcard util/*.h) $(wildcard dsp/tonestack/*.h)
+
+ DEST = $(PREFIX)/lib32/ladspa
+@@ -34,7 +34,7 @@
+ @#python -i bin/rack.py White AutoFilter cream.Audio.Meter Pan
+ @#python -i bin/rack.py White AutoFilter Pan
+ @#python -i bin/rack.py Click Plate
+- @#python -i bin/rack.py PhaserII
++ @#python -i bin/rack.py PhaserII
+ @#~/cream/gdb-python html/graph.py Eq4p,a.f=100,a.gain=30.png
+ @#~/cream/gdb-python bin/eqtest.py
+ @#~/cream/gdb-python bin/fractalstest.py
+@@ -52,10 +52,10 @@
+ $(PLUG).so: $(OBJECTS)
+ $(CC) $(ARCH) $(LDFLAGS) -o $@ $(OBJECTS)
+
+-.cc.s:
++.cc.s:
+ $(CC) $(ARCH) $(CFLAGS) -S $<
+
+-.cc.o: depend
++.cc.o: depend
+ $(CC) $(ARCH) $(CFLAGS) -o $@ -c $<
+
+ tags: $(SOURCES) $(HEADERS)