summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--eatmydata.patch13
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d80824f7cdc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-eatmydata
+ pkgdesc = library and utilities designed to disable fsync and friends (32-bit version)
+ pkgver = 105
+ pkgrel = 3
+ url = https://launchpad.net/libeatmydata
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ conflicts = eatmydata
+ depends = gcc-multilib
+ source = https://launchpad.net/libeatmydata/trunk/release-105/+download/libeatmydata-105.tar.gz
+ source = eatmydata.patch
+ md5sums = 6681166466e589eb0d71177709361256
+ md5sums = c6715ae1204201921af34a374886eea0
+
+pkgname = lib32-eatmydata
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a39e2b0b4346
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributors: Jonathan Squirawski <sky@sky-co.de>, Andrew Dunai <andrew@dun.ai>
+pkgname=lib32-eatmydata
+pkgver=105
+pkgrel=3
+pkgdesc='library and utilities designed to disable fsync and friends'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/libeatmydata'
+license=('GPL3')
+depends=('gcc-multilib')
+conflicts=('eatmydata')
+source=("https://launchpad.net/libeatmydata/trunk/release-${pkgver}/+download/libeatmydata-${pkgver}.tar.gz"
+ 'eatmydata.patch')
+md5sums=('6681166466e589eb0d71177709361256'
+ 'c6715ae1204201921af34a374886eea0')
+
+prepare() {
+ cd libeatmydata-${pkgver}
+ patch -Np1 -i ${srcdir}/eatmydata.patch
+}
+
+build() {
+ cd libeatmydata-${pkgver}
+ ./configure --prefix=/usr --libexecdir=/usr/lib/libeatmydata --build=i686-pc-linux-gnu "CFLAGS=-m32" "CXXFLAGS=-m32" "LDFLAGS=-m32" --libdir=/usr/lib32/ --libexecdir=/usr/lib32/libeatmydata/
+ make
+}
+
+package(){
+ cd libeatmydata-${pkgver}
+ sed -i eatmydata -e 's/\/usr\/lib/\/usr\/lib32/g'
+ make DESTDIR="${pkgdir}" install
+ mv ${pkgdir}/usr/bin/eatmydata ${pkgdir}/usr/bin/eatmydata32
+}
diff --git a/eatmydata.patch b/eatmydata.patch
new file mode 100644
index 000000000000..66b0791a04b3
--- /dev/null
+++ b/eatmydata.patch
@@ -0,0 +1,13 @@
+--- old/eatmydata.in 2015-02-09 09:57:30.182604033 +0100
++++ new/eatmydata.in 2015-02-09 09:58:17.145870310 +0100
+@@ -15,9 +15,7 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-export `dpkg-architecture|grep DEB_BUILD_MULTIARCH`
+-
+-shlib="/usr/lib/$DEB_BUILD_MULTIARCH/eatmydata.sh"
++shlib="/usr/lib/libeatmydata/eatmydata.sh"
+ if [ -f "$shlib" ]; then
+ . "$shlib"
+ else