summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE42
-rw-r--r--PKGBUILD47
-rw-r--r--faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch13
-rw-r--r--faad2-2.7-libmp4ff-shared-lib.patch29
-rw-r--r--faad2-2.7-man1_MANS.patch10
6 files changed, 163 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..556a75c7b864
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lib32-faad2
+ pkgdesc = ISO AAC audio decoder (32 bit)
+ pkgver = 2.7
+ pkgrel = 5
+ url = http://www.audiocoding.com/
+ arch = x86_64
+ license = GPL
+ license = custom:FAAD2
+ depends = lib32-glibc
+ depends = faad2
+ options = !makeflags
+ source = http://downloads.sourceforge.net/sourceforge/faac/faad2-2.7.tar.bz2
+ source = faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
+ source = faad2-2.7-libmp4ff-shared-lib.patch
+ source = faad2-2.7-man1_MANS.patch
+ md5sums = 4c332fa23febc0e4648064685a3d4332
+ md5sums = b33354022bc1696a89b3ccc1ab94c54f
+ md5sums = b23d2853fec6f07ae7769fd4eabd8f42
+ md5sums = a8cee29241a696ab24d010af35b951b8
+
+pkgname = lib32-faad2
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a16abf6e373c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,42 @@
+__________
+COPYRIGHTS
+
+For FAAD2 the following license applies:
+
+******************************************************************************
+** FAAD2 - Freeware Advanced Audio (AAC) Decoder including SBR decoding
+** Copyright (C) 2003-2005 M. Bakker, Nero AG, http://www.nero.com
+**
+** This program is free software; you can redistribute it and/or modify
+** it under the terms of the GNU General Public License as published by
+** the Free Software Foundation; either version 2 of the License, or
+** (at your option) any later version.
+**
+** This program is distributed in the hope that it will be useful,
+** but WITHOUT ANY WARRANTY; without even the implied warranty of
+** MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+** GNU General Public License for more details.
+**
+** You should have received a copy of the GNU General Public License
+** along with this program; if not, write to the Free Software
+** Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+**
+** Any non-GPL usage of this software or parts of this software is strictly
+** forbidden.
+**
+** The "appropriate copyright message" mentioned in section 2c of the GPLv2
+** must read: "Code from FAAD2 is copyright (c) Nero AG, www.nero.com"
+**
+** Commercial non-GPL licensing of this software is possible.
+** For more info contact Nero AG through Mpeg4AAClicense@nero.com.
+******************************************************************************
+
+
+Please note that the use of this software may require the payment of
+patent royalties. You need to consider this issue before you start
+building derivative works. We are not warranting or indemnifying you in
+any way for patent royalities! YOU ARE SOLELY RESPONSIBLE FOR YOUR OWN
+ACTIONS!
+
+
+______
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bbd544c1563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Contributor: josephgbr <rafael.f.f1 at gmail dot com>
+# Contributor: escoand <passtschu at freenet.de>
+
+_pkgname=faad2
+pkgname=lib32-${_pkgname}
+pkgver=2.7
+pkgrel=5
+pkgdesc="ISO AAC audio decoder (32 bit)"
+arch=('x86_64')
+url="http://www.audiocoding.com/"
+license=('GPL' 'custom:FAAD2')
+depends=('lib32-glibc' ${_pkgname})
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/sourceforge/faac/${_pkgname}-${pkgver}.tar.bz2
+ faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
+ faad2-2.7-libmp4ff-shared-lib.patch
+ faad2-2.7-man1_MANS.patch)
+md5sums=('4c332fa23febc0e4648064685a3d4332'
+ 'b33354022bc1696a89b3ccc1ab94c54f'
+ 'b23d2853fec6f07ae7769fd4eabd8f42'
+ 'a8cee29241a696ab24d010af35b951b8')
+
+prepare() {
+cd ${_pkgname}-${pkgver}
+patch -p1 -i "${srcdir}/faad2-2.7-libmp4ff-shared-lib.patch"
+patch -p0 -i "${srcdir}/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch"
+patch -p1 -i "${srcdir}/faad2-2.7-man1_MANS.patch"
+autoreconf --force --install
+}
+
+build() {
+export CC='gcc -m32'
+export CXX='g++ -m32'
+export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+cd ${_pkgname}-${pkgver}
+./configure --prefix=/usr --libdir=/usr/lib32
+make CFLAGS="${CFLAGS} -fPIC"
+}
+
+package() {
+cd ${_pkgname}-${pkgver}
+make DESTDIR="${pkgdir}" install
+rm -rf "${pkgdir}/usr"/{bin,include,share}
+cd ..
+}
diff --git a/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch b/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
new file mode 100644
index 000000000000..5d39cad95d7e
--- /dev/null
+++ b/faad2-2.7-libmp4ff-install-mp4ff_int_types_h.patch
@@ -0,0 +1,13 @@
+Install mp4ff_int_types.h for mythmusic.
+
+http://bugs.gentoo.org/275008
+
+--- common/mp4ff/Makefile.am
++++ common/mp4ff/Makefile.am
+@@ -1,5 +1,5 @@
+ lib_LTLIBRARIES = libmp4ff.la
+-include_HEADERS = mp4ff.h mp4ffint.h
++include_HEADERS = mp4ff.h mp4ffint.h mp4ff_int_types.h
+
+ AM_CFLAGS = -DUSE_TAGGING=1
+
diff --git a/faad2-2.7-libmp4ff-shared-lib.patch b/faad2-2.7-libmp4ff-shared-lib.patch
new file mode 100644
index 000000000000..56a131192969
--- /dev/null
+++ b/faad2-2.7-libmp4ff-shared-lib.patch
@@ -0,0 +1,29 @@
+Ripped from Debian
+
+Patch to create a shared lib for libmp4ff.
+
+--- a/common/mp4ff/Makefile.am
++++ b/common/mp4ff/Makefile.am
+@@ -1,7 +1,8 @@
+-lib_LIBRARIES = libmp4ff.a
++lib_LTLIBRARIES = libmp4ff.la
+ include_HEADERS = mp4ff.h mp4ffint.h
+
+-libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
++AM_CFLAGS = -DUSE_TAGGING=1
+
+-libmp4ff_a_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
++libmp4ff_la_LDFLAGS = -version-info 0:0:0
++libmp4ff_la_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
+ mp4tagupdate.c mp4ff.h mp4ffint.h mp4ff_int_types.h
+--- a/frontend/Makefile.am
++++ b/frontend/Makefile.am
+@@ -5,7 +5,7 @@
+ -I$(top_srcdir)/common/mp4ff
+
+ faad_LDADD = $(top_builddir)/libfaad/libfaad.la \
+- $(top_builddir)/common/mp4ff/libmp4ff.a
++ $(top_builddir)/common/mp4ff/libmp4ff.la
+
+ faad_SOURCES = main.c \
+ audio.c audio.h \
diff --git a/faad2-2.7-man1_MANS.patch b/faad2-2.7-man1_MANS.patch
new file mode 100644
index 000000000000..9c1ddb01bc31
--- /dev/null
+++ b/faad2-2.7-man1_MANS.patch
@@ -0,0 +1,10 @@
+diff -ur faad2-2.7.orig/frontend/Makefile.am faad2-2.7/frontend/Makefile.am
+--- faad2-2.7.orig/frontend/Makefile.am 2009-02-06 18:03:37.000000000 +0200
++++ faad2-2.7/frontend/Makefile.am 2009-07-20 20:27:29.000000000 +0300
+@@ -1,5 +1,5 @@
+ bin_PROGRAMS = faad
+-man_MANS = faad.man
++man1_MANS = faad.man
+
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/common/faad \
+ -I$(top_srcdir)/common/mp4ff