summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eea7090b214f..fb62c2b41d67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jan 30 10:07:25 UTC 2016
+# Sun Apr 17 22:48:10 UTC 2016
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
- pkgver = 2.8.5
+ pkgver = 3.0.1
pkgrel = 1
epoch = 1
url = http://ffmpeg.org/
@@ -19,16 +19,21 @@ pkgbase = lib32-ffmpeg
depends = lib32-gsm
depends = lib32-lame
depends = lib32-libass
+ depends = lib32-libavc1394
depends = lib32-libbluray
+ depends = lib32-libiec61883
depends = lib32-libmodplug
depends = lib32-libpulse
depends = lib32-libtheora
depends = lib32-libva
depends = lib32-libvdpau
depends = lib32-libwebp
+ depends = lib32-opencore-amr
+ depends = lib32-openjpeg
depends = lib32-opus
depends = lib32-schroedinger
depends = lib32-sdl
+ depends = lib32-speex
depends = lib32-v4l-utils
depends = lib32-libxv
depends = lib32-xvidcore
@@ -38,6 +43,8 @@ pkgbase = lib32-ffmpeg
depends = libvorbisenc.so
depends = lib32-libx264
depends = libx264.so
+ depends = lib32-libvpx
+ depends = libvpx.so
optdepends = lib32-ladspa: LADSPA filters
provides = libavcodec.so
provides = libavdevice.so
@@ -48,9 +55,9 @@ pkgbase = lib32-ffmpeg
provides = libpostproc.so
provides = libswresample.so
provides = libswscale.so
- source = http://ffmpeg.org/releases/ffmpeg-2.8.5.tar.bz2
- source = http://ffmpeg.org/releases/ffmpeg-2.8.5.tar.bz2.asc
- sha256sums = 3b6d9951533323ee64a21d0aa7667a780b3470bfe4e0fb7c1b33307ce290615a
+ source = http://ffmpeg.org/releases/ffmpeg-3.0.1.tar.bz2
+ source = http://ffmpeg.org/releases/ffmpeg-3.0.1.tar.bz2.asc
+ sha256sums = f7f7052c120f494dd501f96becff9b5a4ae10cfbde97bc2f1e9f0fd6613a4984
sha256sums = SKIP
pkgname = lib32-ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index 933d0b1cf7df..ebec17bad386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgbasename=ffmpeg
pkgname=lib32-$_pkgbasename
-pkgver=2.8.5
+pkgver=3.0.1
pkgrel=1
epoch=1
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
@@ -15,14 +15,18 @@ license=('GPL3')
depends=("$_pkgbasename"
'lib32-alsa-lib' 'lib32-fontconfig' 'lib32-fribidi'
'lib32-gnutls' 'lib32-gsm' 'lib32-lame' 'lib32-libass'
- 'lib32-libbluray' 'lib32-libmodplug' 'lib32-libpulse'
+ 'lib32-libavc1394'
+ 'lib32-libbluray' 'lib32-libiec61883'
+ 'lib32-libmodplug' 'lib32-libpulse'
'lib32-libtheora' 'lib32-libva' 'lib32-libvdpau'
- 'lib32-libwebp' 'lib32-opus' 'lib32-schroedinger'
- 'lib32-sdl' 'lib32-v4l-utils'
+ 'lib32-libwebp' 'lib32-opencore-amr' 'lib32-openjpeg'
+ 'lib32-opus' 'lib32-schroedinger'
+ 'lib32-sdl' 'lib32-speex' 'lib32-v4l-utils'
'lib32-libxv'
'lib32-xvidcore' 'lib32-zlib'
'lib32-libvorbis' 'libvorbis.so' 'libvorbisenc.so'
'lib32-libx264' 'libx264.so'
+ 'lib32-libvpx' 'libvpx.so'
)
makedepends=('hardening-wrapper' 'lib32-ladspa' 'yasm')
optdepends=('lib32-ladspa: LADSPA filters')
@@ -33,7 +37,7 @@ provides=(
)
source=(http://ffmpeg.org/releases/$_pkgbasename-$pkgver.tar.bz2{,.asc})
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
-sha256sums=('3b6d9951533323ee64a21d0aa7667a780b3470bfe4e0fb7c1b33307ce290615a'
+sha256sums=('f7f7052c120f494dd501f96becff9b5a4ae10cfbde97bc2f1e9f0fd6613a4984'
'SKIP')
build() {
@@ -60,14 +64,20 @@ build() {
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
+ --enable-libiec61883 \
--enable-libmodplug \
--enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
--enable-libopus \
--enable-libpulse \
--enable-libschroedinger \
+ --enable-libspeex \
--enable-libtheora \
--enable-libv4l2 \
--enable-libvorbis \
+ --enable-libvpx \
--enable-libwebp \
--enable-libx264 \
--enable-libxvid \
@@ -76,13 +86,9 @@ build() {
--enable-x11grab
# --enable-libdcadec \
-# --enable-libopencore_amrnb \
-# --enable-libopencore_amrwb \
-# --enable-libopenjpeg \
-# --enable-libspeex \
-# --enable-libvpx \
# --enable-libx265 \
# --enable-libssh \
+# --enable-libsoxr \
# --enable-libvidstab \
make