summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 885722b30454..fbd66d458a6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-libcdio
pkgdesc = GNU Compact Disc Input and Control Library (32-bit)
pkgver = 2.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.gnu.org/software/libcdio/
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index b4446e3078e0..961630424f06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,20 @@
# Contributor: damir <damir@archlinux.org>
pkgname=lib32-libcdio
-_pkgname=libcdio
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Compact Disc Input and Control Library (32-bit)"
-arch=('x86_64')
-license=('GPL3')
-url="https://www.gnu.org/software/libcdio/"
-depends=('lib32-gcc-libs' "libcdio")
-source=(https://ftp.gnu.org/gnu/libcdio/${_pkgname}-${pkgver}.tar.gz{,.sig})
-sha256sums=('1b481b5da009bea31db875805665974e2fc568e2b2afa516f4036733657cf958'
- '1ca33fe6e86266f7829f0d4cdef36e0268144484c86090d6608fa53da782e8ac')
-validpgpkeys=('DAA63BC2582034A02B923D521A8DE5008275EC21') # R. Bernstein
+arch=("x86_64")
+license=("GPL3")
+url="https://www.gnu.org/software/${pkgname#lib32-*}/"
+depends=("lib32-gcc-libs" "${pkgname#lib32-*}")
+source=(https://ftp.gnu.org/gnu/${pkgname#lib32-*}/${pkgname#lib32-*}-${pkgver}.tar.gz{,.sig})
+sha256sums=("1b481b5da009bea31db875805665974e2fc568e2b2afa516f4036733657cf958"
+ "1ca33fe6e86266f7829f0d4cdef36e0268144484c86090d6608fa53da782e8ac")
+validpgpkeys=("DAA63BC2582034A02B923D521A8DE5008275EC21") # R. Bernstein
prepare() {
- cd ${_pkgname}-${pkgver}
+ cd "${pkgname#lib32-*}-${pkgver}"
autoreconf -fi
}
@@ -28,7 +27,7 @@ build() {
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- cd ${_pkgname}-${pkgver}
+ cd "${pkgname#lib32-*}-${pkgver}"
./configure \
--prefix=/usr \
--disable-vcd-info \
@@ -45,8 +44,8 @@ build() {
}
package() {
- cd ${_pkgname}-${pkgver}
+ cd "${pkgname#lib32-*}-${pkgver}"
make -j1 DESTDIR="${pkgdir}" install
- rm -rf ${pkgdir}/usr/bin ${pkgdir}/usr/include ${pkgdir}/usr/share
+ rm -rf "${pkgdir}/usr/bin" "${pkgdir}/usr/include" "${pkgdir}/usr/share"
}