summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bba5cbc1f138..3c9d3d276535 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 11 19:59:07 UTC 2016
+# Thu Dec 15 23:47:38 UTC 2016
pkgbase = lib32-libnotify
pkgdesc = Library for sending desktop notifications (32-bit)
- pkgver = 0.7.6
- pkgrel = 6
+ pkgver = 0.7.7
+ pkgrel = 1
url = https://developer.gnome.org/notification-spec/
arch = x86_64
license = LGPL
@@ -14,7 +14,7 @@ pkgbase = lib32-libnotify
makedepends = lib32-gtk3
depends = libnotify
depends = lib32-gdk-pixbuf2
- source = git://git.gnome.org/libnotify#commit=6b03c47e04e556691445590c15d594aaff5a1066
+ source = git://git.gnome.org/libnotify#commit=c954cabaad9e224c0c6129032d824012d332c11b
sha512sums = SKIP
pkgname = lib32-libnotify
diff --git a/PKGBUILD b/PKGBUILD
index 94fded6ee5df..5c2f3051d658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
# Contributor: Jan de Groot <jgc at archlinux dot org>
pkgname=lib32-libnotify
-pkgver=0.7.6
-pkgrel=6
+pkgver=0.7.7
+pkgrel=1
pkgdesc="Library for sending desktop notifications (32-bit)"
arch=('x86_64')
url="https://developer.gnome.org/notification-spec/"
license=('LGPL')
depends=("${pkgname#lib32-}" 'lib32-gdk-pixbuf2')
makedepends=('gcc-multilib' 'git' 'gnome-common' 'gobject-introspection' 'lib32-gtk3')
-_commit=6b03c47e04e556691445590c15d594aaff5a1066
+_commit=c954cabaad9e224c0c6129032d824012d332c11b # tags/0.7.7^0
source=("git://git.gnome.org/libnotify#commit=$_commit")
sha512sums=('SKIP')
@@ -21,6 +21,11 @@ prepare() {
NOCONFIGURE=1 ./autogen.sh
}
+pkgver() {
+ cd ${pkgname#lib32-}
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
# Modify environment to generate 32-bit ELF. Respects flags defined in makepkg.conf
export CFLAGS="-m32 ${CFLAGS}"