summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f1a4a761b94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lib32-libraw
+ pkgdesc = A library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (32-bit)
+ pkgver = 0.18.2
+ pkgrel = 1
+ url = http://www.libraw.org/
+ arch = x86_64
+ license = CDDL
+ license = LGPL
+ depends = lib32-lcms2
+ depends = lib32-jasper
+ source = http://www.libraw.org/data/LibRaw-0.18.2.tar.gz
+ sha256sums = ce366bb38c1144130737eb16e919038937b4dc1ab165179a225d5e847af2abc6
+
+pkgname = lib32-libraw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52b09ef13f92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: orumin <dev at orum.in>
+
+pkgname=lib32-libraw
+_basename=libraw
+pkgver=0.18.2
+pkgrel=1
+pkgdesc="A library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (32-bit)"
+arch=('x86_64')
+url="http://www.libraw.org/"
+license=(CDDL LGPL)
+depends=(lib32-lcms2 lib32-jasper)
+source=("http://www.libraw.org/data/LibRaw-${pkgver}.tar.gz")
+sha256sums=('ce366bb38c1144130737eb16e919038937b4dc1ab165179a225d5e847af2abc6')
+
+build() {
+ cd LibRaw-$pkgver
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32 \
+ --disable-examples
+ make
+}
+
+package() {
+ cd LibRaw-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "${pkgdir}"/usr/include
+ rm -rf "${pkgdir}"/usr/share
+}