summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
-rw-r--r--g++-6_build.patch28
3 files changed, 50 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a3ae7f887ab..9b47d911f9aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
# Generated by mksrcinfo v8
-# Mon May 16 14:25:24 UTC 2016
+# Sat Aug 6 13:58:11 UTC 2016
pkgbase = lib32-libsidplay
pkgdesc = A library for playing SID music files, lib32.
pkgver = 1.36.59
- pkgrel = 3
+ pkgrel = 4
url = http://critical.ch/distfiles/
arch = x86_64
license = GPL
depends = libsidplay
+ depends = lib32-gcc-libs
options = !libtool
source = http://critical.ch/distfiles/libsidplay-1.36.59.tgz
source = libsidplay-1.36.59-gcc43.patch
+ source = g++-6_build.patch
md5sums = 37c51ba4bd57164b1b0bb7b43b9adece
md5sums = c24d7bca2639f4fee03c40c7dcaadfee
+ md5sums = 4fbea288f7f427818462343e33794356
pkgname = lib32-libsidplay
diff --git a/PKGBUILD b/PKGBUILD
index f7fafe0f8c9b..7ce71db53a0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
# Maintainer: GordonGR <gordongr@freemail.gr>
# Contributor: Kritoke <kritoke@gamebox.net>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=lib32-libsidplay
_pkgname=libsidplay
pkgver=1.36.59
-pkgrel=3
+pkgrel=4
pkgdesc="A library for playing SID music files, lib32."
arch=('x86_64')
url="http://critical.ch/distfiles/"
license=('GPL')
options=('!libtool')
-depends=("${_pkgname}")
+depends=("${_pkgname}" "lib32-gcc-libs")
source=("http://critical.ch/distfiles/${_pkgname}-${pkgver}.tgz"
- "libsidplay-1.36.59-gcc43.patch")
+ "libsidplay-1.36.59-gcc43.patch"
+ "g++-6_build.patch")
md5sums=('37c51ba4bd57164b1b0bb7b43b9adece'
- 'c24d7bca2639f4fee03c40c7dcaadfee')
+ 'c24d7bca2639f4fee03c40c7dcaadfee'
+ '4fbea288f7f427818462343e33794356')
+
prepare() {
-cd ${srcdir}/${_pkgname}-${pkgver}
-patch -Np1 -i $srcdir/libsidplay-1.36.59-gcc43.patch
+cd ${_pkgname}-${pkgver}
+patch -Np1 -i ../libsidplay-1.36.59-gcc43.patch
+patch -Np1 -i ../g++-6_build.patch
}
build() {
-cd ${srcdir}/${_pkgname}-${pkgver}
+cd ${_pkgname}-${pkgver}
export CC="gcc -m32"
export CXX="g++ -m32 -Wno-narrowing"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
@@ -33,8 +38,9 @@ make
}
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
- cd "$pkgdir/usr"
- rm -rf include/
+cd ${_pkgname}-${pkgver}
+make DESTDIR=${pkgdir} install
+
+cd "$pkgdir/usr"
+rm -rf include/
}
diff --git a/g++-6_build.patch b/g++-6_build.patch
new file mode 100644
index 000000000000..91e206447ebb
--- /dev/null
+++ b/g++-6_build.patch
@@ -0,0 +1,28 @@
+Description: use unsigned char to keep int value
+ Use unsigned char to keep all bits of int values in the array.
+Author: Laszlo Boszormenyi (GCS) <gcs@debian.org>
+Bug-Debian: https://bugs.debian.org/811762
+Last-Update: 2016-07-16
+
+---
+
+--- libsidplay-1.36.59.orig/src/samples.cpp
++++ libsidplay-1.36.59/src/samples.cpp
+@@ -75,7 +75,7 @@ struct sampleChannel
+ sampleChannel ch4, ch5;
+
+
+-const sbyte galwayNoiseTab1[16] =
++const ubyte galwayNoiseTab1[16] =
+ {
+ 0x80,0x91,0xa2,0xb3,0xc4,0xd5,0xe6,0xf7,
+ 0x08,0x19,0x2a,0x3b,0x4c,0x5d,0x6e,0x7f
+@@ -84,7 +84,7 @@ const sbyte galwayNoiseTab1[16] =
+ ubyte galwayNoiseVolTab[16];
+ sbyte galwayNoiseSamTab[16];
+
+-const sbyte sampleConvertTab[16] =
++const ubyte sampleConvertTab[16] =
+ {
+ // 0x81,0x99,0xaa,0xbb,0xcc,0xdd,0xee,0xff,
+ // 0x00,0x11,0x22,0x33,0x44,0x55,0x66,0x7f