summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Set-where-find-and-install-32-bits-libraries.patch54
-rw-r--r--PKGBUILD17
-rw-r--r--Set-where-find-and-install-32-bits-libraries.patch54
4 files changed, 70 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4aaafa95c5a..774eabe1d90e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Feb 1 12:45:16 UTC 2016
pkgbase = lib32-libtins
- pkgdesc = 32-bit A high-level, multiplatform C++ network packet sniffing and crafting library
- pkgver = 3.2
+ pkgdesc = A high-level, multiplatform C++ network packet sniffing and crafting library (32-bit) version
+ pkgver = 3.3
pkgrel = 1
url = http://libtins.github.io/
arch = x86_64
@@ -10,10 +12,10 @@ pkgbase = lib32-libtins
depends = lib32-openssl
depends = libtins
options = !libtool
- source = https://github.com/mfontanini/libtins/archive/v3.2.tar.gz
- source = Set-where-find-and-install-32-bits-libraries.patch
- sha256sums = 7f11c8b6c33574fcc48a5310557320d7eff7216d28e6f7062ea3e4745f2ce4fc
- sha256sums = 97d41800372ebf25dff241fb84c58e1d798cc9fc16c17b0e528a5f28efcfd99d
+ source = https://github.com/mfontanini/libtins/archive/v3.3.tar.gz
+ source = 0001-Set-where-find-and-install-32-bits-libraries.patch
+ sha256sums = a2d9b8a4dd0b2a4d0d1924d2b2b03ea76a7ceb241f91c6a7ed262a1a7d64d94d
+ sha256sums = cda02bbdf6edf95b6adaef57b1c4122dae26932c8ff4465e00183b0403a85e34
pkgname = lib32-libtins
diff --git a/0001-Set-where-find-and-install-32-bits-libraries.patch b/0001-Set-where-find-and-install-32-bits-libraries.patch
new file mode 100644
index 000000000000..78177f05e1bb
--- /dev/null
+++ b/0001-Set-where-find-and-install-32-bits-libraries.patch
@@ -0,0 +1,54 @@
+From 6a07e64fd13fe35499d9e7b3dbaf968a201652a6 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Javier=20Ti=C3=A1?= <javier.tia@gmail.com>
+Date: Mon, 1 Feb 2016 06:38:30 -0600
+Subject: [PATCH] Set where find and install 32-bits libraries
+
+---
+ CMakeLists.txt | 2 +-
+ cmake/Modules/FindPCAP.cmake | 2 +-
+ src/CMakeLists.txt | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7ddffe1..79f40a5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -135,7 +135,7 @@ CONFIGURE_FILE(
+ )
+
+ # Support for pkg-config
+-SET(CMAKE_INSTALL_LIBDIR lib)
++SET(CMAKE_INSTALL_LIBDIR lib32)
+ SET(pkgconfig_prefix ${CMAKE_INSTALL_PREFIX})
+ SET(pkgconfig_exec_prefix ${CMAKE_INSTALL_PREFIX})
+ SET(pkgconfig_libdir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+diff --git a/cmake/Modules/FindPCAP.cmake b/cmake/Modules/FindPCAP.cmake
+index ecc32fb..c01fa76 100644
+--- a/cmake/Modules/FindPCAP.cmake
++++ b/cmake/Modules/FindPCAP.cmake
+@@ -29,7 +29,7 @@ find_path(PCAP_INCLUDE_DIR
+ HINTS ${PCAP_ROOT_DIR}/include
+ )
+
+-set (HINT_DIR ${PCAP_ROOT_DIR}/lib)
++set (HINT_DIR ${PCAP_ROOT_DIR}/lib32)
+
+ # On x64 windows, we should look also for the .lib at /lib/x64/
+ # as this is the default path for the WinPcap developer's pack
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 66b8c50..cfdae02 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -75,7 +75,7 @@ SET_TARGET_PROPERTIES(tins PROPERTIES VERSION ${LIBTINS_VERSION} SOVERSION ${LIB
+ INSTALL(
+ TARGETS tins
+ EXPORT libtinsTargets
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION lib32
++ ARCHIVE DESTINATION lib32
+ COMPONENT dev
+ )
+--
+2.7.0
+
diff --git a/PKGBUILD b/PKGBUILD
index b967c700f073..5f4c10976029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Javier Tia <javier.tia at gmail dot com>
pkgname=lib32-libtins
-pkgver=3.2
+pkgver=3.3
pkgrel=1
-pkgdesc="32-bit A high-level, multiplatform C++ network packet sniffing and crafting library"
+pkgdesc="A high-level, multiplatform C++ network packet sniffing and crafting library (32-bit) version"
arch=('x86_64')
url="http://libtins.github.io/"
license=('BSD')
@@ -12,18 +12,16 @@ makedepends=('cmake')
options=('!libtool')
source=(
"https://github.com/mfontanini/libtins/archive/v${pkgver}.tar.gz"
- "Set-where-find-and-install-32-bits-libraries.patch"
+ "0001-Set-where-find-and-install-32-bits-libraries.patch"
)
-sha256sums=(
- '7f11c8b6c33574fcc48a5310557320d7eff7216d28e6f7062ea3e4745f2ce4fc'
- '97d41800372ebf25dff241fb84c58e1d798cc9fc16c17b0e528a5f28efcfd99d'
-)
+sha256sums=('a2d9b8a4dd0b2a4d0d1924d2b2b03ea76a7ceb241f91c6a7ed262a1a7d64d94d'
+ 'cda02bbdf6edf95b6adaef57b1c4122dae26932c8ff4465e00183b0403a85e34')
prepare() {
cd "${srcdir}"/libtins-${pkgver}
mkdir build
- patch -Np1 -i ${srcdir}/Set-where-find-and-install-32-bits-libraries.patch
+ patch -Np1 -i ${srcdir}/${source[1]}
}
build() {
@@ -33,7 +31,7 @@ build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cmake -D CMAKE_BUILD_TYPE=Release -D LIBTINS_ENABLE_CXX11=yes \
-D CMAKE_INSTALL_PREFIX=/usr ../
- make -j8
+ make
}
package() {
@@ -42,3 +40,4 @@ package() {
rm -R "${pkgdir}"/usr/{CMake,include}/
}
+# vim:set ft=sh ts=2 sw=2 et:
diff --git a/Set-where-find-and-install-32-bits-libraries.patch b/Set-where-find-and-install-32-bits-libraries.patch
deleted file mode 100644
index db3b77039c2e..000000000000
--- a/Set-where-find-and-install-32-bits-libraries.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 1d01cfbe5efc8f7e594a38fe7ef37aa552059c7b Mon Sep 17 00:00:00 2001
-From: Javier Tia <javier.tia@hp.com>
-Date: Wed, 25 Mar 2015 09:33:09 -0600
-Subject: [PATCH] Set where find and install 32-bits libraries
-
----
- CMakeLists.txt | 2 +-
- cmake/Modules/FindPCAP.cmake | 2 +-
- src/CMakeLists.txt | 4 ++--
- 3 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 726d6ce..16643db 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -107,7 +107,7 @@ CONFIGURE_FILE(
- )
-
- # Support for pkg-config
--set(CMAKE_INSTALL_LIBDIR lib)
-+set(CMAKE_INSTALL_LIBDIR lib32)
- set(pkgconfig_prefix ${CMAKE_INSTALL_PREFIX})
- set(pkgconfig_exec_prefix ${CMAKE_INSTALL_PREFIX})
- set(pkgconfig_libdir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
-diff --git a/cmake/Modules/FindPCAP.cmake b/cmake/Modules/FindPCAP.cmake
-index b3a3075..651f638 100644
---- a/cmake/Modules/FindPCAP.cmake
-+++ b/cmake/Modules/FindPCAP.cmake
-@@ -30,7 +30,7 @@ find_path(PCAP_INCLUDE_DIR
-
- find_library(PCAP_LIBRARY
- NAMES pcap wpcap
-- HINTS ${PCAP_ROOT_DIR}/lib
-+ HINTS ${PCAP_ROOT_DIR}/lib32
- )
-
- include(FindPackageHandleStandardArgs)
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 25a93ce..73605c6 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -69,7 +69,7 @@ SET_TARGET_PROPERTIES(tins PROPERTIES VERSION ${LIBTINS_VERSION} SOVERSION ${LIB
- INSTALL(
- TARGETS tins
- EXPORT libtinsTargets
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ LIBRARY DESTINATION lib32
-+ ARCHIVE DESTINATION lib32
- COMPONENT dev
- )
---
-2.3.3
-