summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
-rw-r--r--liblua.so.patch55
3 files changed, 50 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8a5ef2f9abb..cc5127e4f7c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-lua
pkgdesc = A powerful light-weight programming language designed for extending applications
- pkgver = 5.2.4
+ pkgver = 5.3.1
pkgrel = 1
url = http://www.lua.org/
arch = x86_64
@@ -9,12 +9,12 @@ pkgbase = lib32-lua
depends = lib32-readline
options = !makeflags
options = !emptydirs
- source = http://www.lua.org/ftp/lua-5.2.4.tar.gz
- source = liblua.so.patch
+ source = http://www.lua.org/ftp/lua-5.3.1.tar.gz
source = lua.pc
- md5sums = 913fdb32207046b273fdb17aad70be13
- md5sums = a83c29ea76deedc8e30037952fa2429a
- md5sums = ffbf1ddbe711b604585c535ed1e3eb81
+ source = liblua.so.patch
+ sha1sums = 1676c6a041d90b6982db8cef1e5fb26000ab6dee
+ sha1sums = 1fde8d1b96f0e2016678cca5b12cad00df300464
+ sha1sums = 863ca67b55136f8360350c6e4873ebeb1263dde2
pkgname = lib32-lua
diff --git a/PKGBUILD b/PKGBUILD
index 558d6b761a67..bcf0506c764f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,31 @@
# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-pkgname=lib32-lua
-pkgver=5.2.4
+pkgname=lib32-lua
+pkgver=5.3.1
pkgrel=1
-pkgdesc="A powerful light-weight programming language designed for extending applications"
+pkgdesc="A powerful light-weight programming language designed for extending applications"
arch=('x86_64')
url="http://www.lua.org/"
depends=('lua' 'lib32-readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
source=("http://www.lua.org/ftp/lua-${pkgver}.tar.gz"
- 'liblua.so.patch' 'lua.pc')
-md5sums=('913fdb32207046b273fdb17aad70be13'
- 'a83c29ea76deedc8e30037952fa2429a'
- 'ffbf1ddbe711b604585c535ed1e3eb81')
+ 'lua.pc'
+ 'liblua.so.patch')
+sha1sums=('1676c6a041d90b6982db8cef1e5fb26000ab6dee'
+ '1fde8d1b96f0e2016678cca5b12cad00df300464'
+ '863ca67b55136f8360350c6e4873ebeb1263dde2')
-build() {
+prepare() {
cd "${srcdir}/lua-${pkgver}"
+
patch -p1 -i "${srcdir}/liblua.so.patch"
+}
+
+build() {
+ cd "${srcdir}/lua-${pkgver}"
+
export CFLAGS="${CFLAGS/-march=x86-64} -march=i686 -m32 -fPIC"
export LDFLAGS="${LDFLAGS/-march=x86-64} -march=i686 -m32"
@@ -30,7 +37,7 @@ build() {
package() {
cd "${srcdir}/lua-${pkgver}"
make \
- TO_LIB="liblua.a liblua.so liblua.so.5.2 liblua.so.$pkgver" \
+ TO_LIB="liblua.a liblua.so liblua.so.5.3 liblua.so.$pkgver" \
INSTALL_DATA="cp -d" \
INSTALL_TOP="${pkgdir}/usr" \
install
diff --git a/liblua.so.patch b/liblua.so.patch
index be1ef85c0b8d..f1cb460db3e0 100644
--- a/liblua.so.patch
+++ b/liblua.so.patch
@@ -1,51 +1,51 @@
-diff -ru lua-5.2.1/Makefile lua-5.2.1.new/Makefile
---- lua-5.2.1/Makefile 2012-05-17 16:05:54.000000000 +0200
-+++ lua-5.2.1.new/Makefile 2012-09-12 22:39:07.162748096 +0200
+diff -aur lua-5.3.1.orig/Makefile lua-5.3.1/Makefile
+--- lua-5.3.1.orig/Makefile 2015-06-03 03:35:35.000000000 +0200
++++ lua-5.3.1/Makefile 2015-07-03 05:23:04.606683081 +0200
@@ -52,7 +52,7 @@
all: $(PLAT)
-
+
$(PLATS) clean:
- cd src && $(MAKE) $@
+ cd src && $(MAKE) $@ V=$(V) R=$(R)
-
+
test: dummy
- src/lua -v
-diff -ru lua-5.2.1/src/luaconf.h lua-5.2.1.new/src/luaconf.h
---- lua-5.2.1/src/luaconf.h 2012-05-11 16:14:42.000000000 +0200
-+++ lua-5.2.1.new/src/luaconf.h 2012-09-12 22:40:27.986622772 +0200
-@@ -100,7 +100,7 @@
+ src/lua -v
+diff -aur lua-5.3.1.orig/src/luaconf.h lua-5.3.1/src/luaconf.h
+--- lua-5.3.1.orig/src/luaconf.h 2015-05-20 19:39:23.000000000 +0200
++++ lua-5.3.1/src/luaconf.h 2015-07-03 05:23:16.425442874 +0200
+@@ -188,7 +188,7 @@
+
#else /* }{ */
-
- #define LUA_VDIR LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
+
-#define LUA_ROOT "/usr/local/"
+#define LUA_ROOT "/usr/"
- #define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR
- #define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR
+ #define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR "/"
+ #define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR "/"
#define LUA_PATH_DEFAULT \
-diff -ru lua-5.2.1/src/Makefile lua-5.2.1.new/src/Makefile
---- lua-5.2.1/src/Makefile 2012-03-09 17:32:16.000000000 +0100
-+++ lua-5.2.1.new/src/Makefile 2012-09-12 22:38:08.591386896 +0200
+diff -aur lua-5.3.1.orig/src/Makefile lua-5.3.1/src/Makefile
+--- lua-5.3.1.orig/src/Makefile 2015-05-27 13:10:11.000000000 +0200
++++ lua-5.3.1/src/Makefile 2015-07-03 05:23:04.606683081 +0200
@@ -29,6 +29,7 @@
- PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
-
+ PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
+
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
- lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
- ltm.o lundump.o lvm.o lzio.o
+ lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+ ltm.o lundump.o lvm.o lzio.o
@@ -43,7 +44,7 @@
LUAC_O= luac.o
-
+
ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
+ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
ALL_A= $(LUA_A)
-
+
# Targets start here.
@@ -59,6 +60,12 @@
- $(AR) $@ $(BASE_O)
- $(RANLIB) $@
-
+ $(AR) $@ $(BASE_O)
+ $(RANLIB) $@
+
+$(LUA_SO): $(CORE_O) $(LIB_O)
+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
@@ -53,4 +53,5 @@ diff -ru lua-5.2.1/src/Makefile lua-5.2.1.new/src/Makefile
+
+
$(LUA_T): $(LUA_O) $(LUA_A)
- $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+ $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+