summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cda8e5a8d02f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libaperture-git
+ pkgdesc = A camera library for GTK3
+ pkgver = 10f7a18
+ pkgrel = 1
+ url = https://gitlab.gnome.org/jwestman/libaperture
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = vala
+ depends = gtk3
+ depends = gobject-introspection
+ provides = libaperture
+ conflicts = libaperture
+ source = libaperture::git+https://gitlab.gnome.org/jwestman/libaperture
+ sha256sums = SKIP
+
+pkgname = libaperture-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4265a046e88e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gabriele Musco <gabmus@disroot.org>
+# Upstream URL: https://gitlab.gnome.org/jwestman/libaperture
+
+pkgname=libaperture-git
+pkgver=10f7a18
+pkgrel=1
+pkgdesc='A camera library for GTK3'
+arch=('any')
+url='https://gitlab.gnome.org/jwestman/libaperture'
+license=('GPL3')
+depends=(
+ 'vala'
+ 'gtk3'
+ 'gobject-introspection'
+)
+makedepends=('git' 'meson')
+provides=('libaperture')
+conflicts=('libaperture')
+source=("libaperture::git+https://gitlab.gnome.org/jwestman/libaperture")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/libaperture"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/libaperture"
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr --buildtype release ..
+ ninja
+}
+
+package() {
+ cd "$srcdir/libaperture"
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}