summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--libarstream2-Makefile5
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5b03a313539..59b6ba79cb76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libarstream2-git
pkgdesc = Parrot Streaming Library
pkgver = r156.bcd93a5
- pkgrel = 1
+ pkgrel = 2
url = http://developer.parrot.com/
arch = x86_64
license = custom
@@ -12,7 +12,7 @@ pkgbase = libarstream2-git
source = Config-linux-config.h
source = LICENSE
sha256sums = SKIP
- sha256sums = b48204d27c7cb89c18e062d2d953639fc1d090f48ff2deb5edf75ed94f138eb8
+ sha256sums = c1554a5e0b68e1d5b9e08434b509b78215fb89d2aa64ced5fc53f2680982df3c
sha256sums = 5956b54ef47ad26df51991a4aa7002abdcb524a51b455d040f55b4d11a4f44a7
sha256sums = 1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb
diff --git a/PKGBUILD b/PKGBUILD
index bbec25b268a3..e373fd4ada3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=libarstream2-git
pkgver=r156.bcd93a5
-pkgrel=1
+pkgrel=2
pkgdesc="Parrot Streaming Library"
arch=(x86_64)
url="http://developer.parrot.com/"
@@ -26,7 +26,7 @@ source=('libarstream2::git+https://github.com/Parrot-Developers/libARStream2'
'Config-linux-config.h'
'LICENSE')
sha256sums=('SKIP'
- 'b48204d27c7cb89c18e062d2d953639fc1d090f48ff2deb5edf75ed94f138eb8'
+ 'c1554a5e0b68e1d5b9e08434b509b78215fb89d2aa64ced5fc53f2680982df3c'
'5956b54ef47ad26df51991a4aa7002abdcb524a51b455d040f55b4d11a4f44a7'
'1771e95329e9cb2bed04e023e330af3d558d0f13c0c1c5de0581f2880f149deb')
diff --git a/libarstream2-Makefile b/libarstream2-Makefile
index 7c6489d22323..2a2cc456e6a4 100644
--- a/libarstream2-Makefile
+++ b/libarstream2-Makefile
@@ -1,6 +1,7 @@
CC = gcc
CFLAGS = -fPIC -Wall -Wextra -O2 -g -IIncludes -DHAVE_CONFIG_H
-LDFLAGS = -shared
+LIBS = -larsal -lm
+LDFLAGS = -shared -Wl,-O1,-as-needed,-no-undefined,-z,relro,-z,now
RM = rm -f
TARGET_LIB = libarstream2.so
@@ -19,7 +20,7 @@ OBJS = $(SRCS:.c=.o)
all: ${TARGET_LIB}
$(TARGET_LIB): $(OBJS)
- $(CC) ${LDFLAGS} -o $@ $^
+ $(CC) ${LDFLAGS} -o $@ $^ ${LIBS}
$(SRCS:.c=.d):%.d:%.c
$(CC) $(CFLAGS) -MM $< >$@