summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 317cd6688ccc..0384c5479701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = libbdplus-git
pkgdesc = Open implementation of BD+ protocol. (GIT version)
- pkgver = 0.1.2.35.g1472680
+ pkgver = 0.2.0.0.g98a4ba1
pkgrel = 1
url = http://www.videolan.org/developers/libbdplus.html
arch = x86_64
license = LGPL
makedepends = git
+ depends = glibc
depends = libaacs
+ depends = libgpg-error
+ depends = libgcrypt
provides = libbdplus
provides = libbdplus.so
conflicts = libbdplus
@@ -14,4 +17,3 @@ pkgbase = libbdplus-git
sha256sums = SKIP
pkgname = libbdplus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0ccfca285e26..009bcb12f4a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=libbdplus-git
-pkgver=0.1.2.35.g1472680
+pkgver=0.2.0.0.g98a4ba1
pkgrel=1
pkgdesc="Open implementation of BD+ protocol. (GIT version)"
arch=('x86_64')
license=('LGPL')
url='http://www.videolan.org/developers/libbdplus.html'
-depends=('libaacs')
+depends=(
+ 'glibc' # libc.so
+ 'libaacs'
+ 'libgpg-error' # libgpg-error.so
+ 'libgcrypt' # libgcrypt.so
+)
makedepends=('git')
-provides=('libbdplus'
- 'libbdplus.so'
- )
+provides=(
+ 'libbdplus'
+ 'libbdplus.so'
+)
conflicts=('libbdplus')
source=('git+https://code.videolan.org/videolan/libbdplus.git')
sha256sums=('SKIP')
@@ -23,13 +29,15 @@ pkgver() {
prepare() {
mkdir -p build
+
+ sed 's|gpg-error-config|gpg-error|g' -i libbdplus/configure.ac
+}
+build() {
cd libbdplus
autoreconf -vfi
-}
-build() {
- cd build
+ cd ../build
../libbdplus/configure \
--prefix=/usr \
--disable-static