summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da2e4c31cf22..dfec9c84060a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Mar 7 21:37:24 UTC 2017
pkgbase = libbobcat
pkgdesc = Bobcat (Brokken's Own Base Classes And Templates) library
- pkgver = 4.07.00
+ pkgver = 4.08.03
pkgrel = 1
url = https://fbb-git.github.io/bobcat/
arch = i686
@@ -16,8 +14,8 @@ pkgbase = libbobcat
makedepends = yodl>=3.07.01
depends = openssl
depends = libx11>=1.6.2
- source = https://github.com/fbb-git/bobcat/archive/4.07.00.tar.gz
- md5sums = aadac2d39b955147caf4e3da8674d57e
+ source = https://github.com/fbb-git/bobcat/archive/4.08.03.tar.gz
+ md5sums = f90bb919b09a9f2d1cdcd6cb61892f4a
pkgname = libbobcat
diff --git a/PKGBUILD b/PKGBUILD
index d67a029176f3..1cafad63271c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kevin Brodsky <corax26 at gmail dot com>
# Contributor: Anton Jongsma <anton@felrood.nl>
pkgname=libbobcat
-pkgver=4.07.00
+pkgver=4.08.03
pkgrel=1
pkgdesc="Bobcat (Brokken's Own Base Classes And Templates) library"
arch=('i686' 'x86_64')
@@ -13,12 +13,18 @@ makedepends=('icmake>=8.01.00' 'openssl' 'readline' 'libmilter>=8.14.4'
'libx11>=1.6.2' 'yodl>=3.07.01')
optdepends=()
source=("https://github.com/fbb-git/bobcat/archive/${pkgver}.tar.gz")
-md5sums=('aadac2d39b955147caf4e3da8674d57e')
+md5sums=('f90bb919b09a9f2d1cdcd6cb61892f4a')
build() {
cd "$srcdir/bobcat-${pkgver}/bobcat"
- CXXFLAGS="$CXXFLAGS -std=c++14"
+ # Explicitly define CXX, because since 4.08.03 the build system defines it
+ # by default to g++-8, which doesn't make sense on Arch.
+ export CXX="g++"
+ # Since makepkg always defines CXXFLAGS, it overrides the default value
+ # defined in the build system, which is problematic because it needs a
+ # specific C++ version. Add it back here.
+ CXXFLAGS="$CXXFLAGS -std=c++17"
# Add the -P option not to use precompiled headers, which can be useful since
# they require a lot of free space, compared to a normal compilation:
# ./build -P libraries all